PowerFlex: SSDs are reported as SED drives after upgrading iDRAC to 4.22.00.00 or 4.32.10.00

Summary: Intel SATA SSDs are incorrectly reported as SED after upgrading iDRAC from 4.20.20.20 to 4.22.00.00 or higher using iDRAC API. If the disk is queried using OS, it appears as no SED disk as expected. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When we upgrade the iDRAC from 4.20.20.20 to 4.22.00.00 or higher, Intel SATA SSD drives are identified as SED using iDRAC API. Due to this issue an admin might mistakenly try to add them manually to Cloud link as a SED disk, which cause an error.


 

Cause

This issue is seen with Dell PowerEdge iDRAC versions: 4.22.00.00, 4.32.10.00

Resolution

Systems using CloudLink should not update to iDRAC versions: 4.22.00.00, 4.32.10.00


Workaround if Upgraded:
Search the disk Part number (using google search) and identify whether it is an SED disk or Non-SED disk, if it is a Non-SED disk add it using software encryption option in Cloud link.


Support for PowerFlex Ready node: 
Validate whether the drive is an SSD or SED and leaves the iDRAC version on 4.20.20.20.

NOTE: The issue is fixed in iDRAC version 4.40.10.00

 

Affected Products

CloudLink SecureVM, VxFlex Ready Nodes, CloudLink, VxFlex Ready Node, VxFlex Ready Node R640, VxFlex Ready Node R740xd, Ready Node Series, VxFlex Ready Node R840
Article Properties
Article Number: 000184002
Article Type: Solution
Last Modified: 25 Nov 2025
Version:  3
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