VxRail: iSM "is not running" "running limited functionality," or "is inactive (dead)"

Summary: The iSM is in a state of "is not running" or "running limited functionality." This article describes methods of resolving.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The iDRAC Service Module (iSM) is an important service on hosts to be able to gather information from the iDRAC for monitoring.

This can show up in the iDRAC as the following state.
IDRAC UI showing Service Module Status

To check the iSM service status:
All VxRail through 7.0.x

/etc/init.d/dcism-netmon-watchdog status

8.0+

/etc/init.d/dellism status

They may have one of the following statuses:

  • iSM is active (running)
    • This is the fully functional state
  • iSM is active (not running)
  • iSM is active (running limited functionality)
  • iSM is inactive (dead)

 

Cause

There are many possible causes of this issue. One such example is that the services on the iDRAC are not fully functional, preventing the iSM from talking with it.

Any individual root cause should be investigated under normal technical review (logs, release notes, Knowledge Base articles (KBs), so on) and escalated as necessary using standard processes (CTE, DE, EE).

 

Resolution

NOTE: As of VxRail 8.0, the iSM service script is renamed.

To resolve this issue, follow the steps below:

  • Open an SSH session to each node that has the iSM not running on IDRAC.

Follow the steps below on each of the nodes:

  1. First, cold reboot the iDRAC to reboot its operating system. Each of the following methods is ways of accomplishing this task; it is not necessarily to run all three because of this.

    /opt/vxrail/tools/ipmitool mc reset cold
    
    SSH into iDRAC (same login as web)
    racadm> racreset hard
  2. Stop iSM service on the node.

    7.0.x and earlier
    # /etc/init.d/dcism-netmon-watchdog stop
    8.0
    # /etc/init.d/dellism stop
  3. Install iSMPKIHelper

    # cd /opt/dell/srvadmin/iSM/bin
    # ./Invoke-iSMPKIHelper -install
  4. Start iSM service on node.

    7.0.x and earlier
    # /etc/init.d/dcism-netmon-watchdog start
    8.0
    # /etc/init.d/dellism start
  5. Set service from 0 to 1

    # esxcli system wbem set -e 0
    # esxcli system wbem set -e 1
  6. Run the SupportAssistCollection script to collect iDRAC logs

    # cd /opt/dell/srvadmin/iSM/bin
    # ./Invoke-SupportAssistCollection
    SupportAssist log Collection is in progress.. 
    [||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||]100% 
    Downloading the collected log file is in progress.. 
    SupportAssist Collection logs can be found in path /tmp/TSR20190826xxxxxx_xxxxxx.zip
NOTE: The iSM can take a few minutes before it is in a full running state. It is recommended to give 5 minutes for the iSM to start before trying and also after applying the next step.

If the iSM is "active (not running)," and cannot recover by "/etc/init.d/dcism-netmon-watchdog restart" or "/etc/init.d/dellism": it may be related to the following service.
Try the following steps.

/etc/init.d/dcism-netmon-watchdog status
/etc/init.d/sfcbd-watchdog stop
/etc/init.d/sfcbd-watchdog start
/etc/init.d/dcism-netmon-watchdog restart
/etc/init.d/dcism-netmon-watchdog status

The following work same as above:
7.0.x and older

/opt/vxrail/tools/ipmitool mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dcism-netmon-watchdog stop; /etc/init.d/vxrail-pservice stop; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dcism-netmon-watchdog start; sleep 120 ; /etc/init.d/vxrail-pservice start

8.0

/opt/vxrail/tools/ipmitool mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dellism stop; /etc/init.d/vxrail-pservice stop; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dellism start; sleep 120 ; /etc/init.d/vxrail-pservice start

8.0.3xx:

/opt/platformsvc/bin/ipmitool.sh mc reset cold ; sleep 300 ; /etc/init.d/sfcbd-watchdog stop ; /etc/init.d/dellism stop; esxcli daemon control stop -s platformsvc; rm /var/run/log/vxps_cache.dat ; sleep 10 ; /etc/init.d/sfcbd-watchdog start ; /etc/init.d/dellism start; sleep 120 ; esxcli daemon control start -s platformsvc



If the iSM state is "inactive (dead)," restarting the iSM service does not change its state from dead. Attempting to remove, upgrade, or install over the iSM leads to the following error.

It is not safe to continue. Please reboot the host immediately to discard the unfinished update.
cause = ('DEL-dcism(4.1.0.0.2410-DEL.700.0.0.15843807)', "Failed to unmount tardisk dcism.v00 of VIB DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Error in running [rm /tardisks/dcism.v00]:\nReturn code: 1\nOutput: rm: can't remove '/tardisks/dcism.v00': Device or resource busy\n")
vibs = ['DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807']
Please refer to the log file for more details.
[root@nl93vh1012:/tardisks] localcli software vib remove -n dcism
Errors:
[LiveInstallationError]
DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Failed to unmount tardisk dcism.v00 of VIB DEL_bootbank_dcism_4.1.0.0.2410-DEL.700.0.0.15843807: Error in running [rm /tardisks/dcism.v00]:
Return code: 1
Output: rm: can't remove '/tardisks/dcism.v00': Device or resource busy

Stop the service to have it release its access to the above tardisk. iSM processes can start backup after this.

/etc/init.d/sfcbd-watchdog stop

Then you can retry the upgrade or immediately update the iSM manually as:

esxcli software vib update -d /vmfs/volumes/vsan\:*/upgradeBundles-*/<ISM version being upgraded to>.zip

Where the vSAN upgradeBundles folders involve UUIDs and the ISM version depends what the VxRail upgrade is being upgraded to.

If this does not resolve the issue, you may have to power drain the node.
It is recommended to first try a virtual power drain as it can be done remotely. Physical power drain requires physical access.
Dell EMC VxRail: How to perform remote auxiliary power drain of node through the iDRAC (Dell Support account is required to view this article)

If issues continue, it is recommended to engage Dell Technical Support for assistance; reference this KB.

 

Affected Products

VxRail 460 and 470 Nodes, VxRail D560, VxRail D560F, VxRail E460, VxRail E560, VxRail E560 VCF, VxRail E560F, VxRail E560F VCF, VxRail E560N, VxRail E560N VCF

Products

VxRail E660, VxRail E660F, VxRail E660N, VxRail E665, VxRail E665F, VxRail E665N, VxRail G560, VxRail G560 VCF, VxRail G560F, VxRail G560F VCF, VxRail P470, VxRail P570, VxRail P570 VCF, VxRail P570F, VxRail P570F VCF, VxRail P580N, VxRail P580N VCF , VxRail P670F, VxRail P670N, VxRail P675F, VxRail P675N, VxRail S470, VxRail S570, VxRail S570 VCF, VxRail S670, VxRail V470, VxRail V570, VxRail V570 VCF, VxRail V570F, VxRail V570F VCF, VXRAIL V670F, VxRail VD-4000R, VxRail VD-4000W, VxRail VD-4000Z, VxRail VD-4510C, VxRail VD-4520C, VxRail VE-660, VxRail VE-6615, VxRail VP-760, VxRail VP-7625, VxRail VS-760 ...
Article Properties
Article Number: 000042093
Article Type: Solution
Last Modified: 22 Sep 2025
Version:  24
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