Unisphere unable to register to CloudIQ after upgrading ESRS to SCG Secure Connect Gateway
Summary: This article explains a situation when upgrading to Secure Connect Gateway (SCG) from ESRS customer is unable to register Unisphere with CloudIQ.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The array may show disconnected in CloudIQ after the upgrade to SCG, if the customer attempts to re-register the new registration fails with Error:
Could not connect to SRS Gateway.
After attempts to register the collection.log show a message similar to this:
Response code 400 in the ESRS response body: Device matches not found for input device with Serial Number ELMUSPxxxxxxxx and UNISPHERE.
Cause
The SCG does not recognize the Unisphere serial number that was used in ESRS.
Resolution
It is mandatory to force a new registration Serial ID for Unisphere so that SCG can log the new Serial as the correct serial for the Unisphere instance.
If Embedded:
Rename the:
ProductSerialNumber.pers ------ /opt/emc/SMAS/jboss/standalone/data/esrs/productserialnumber.pers mv /opt/emc/SMAS/jboss/standalone/data/esrs/productserialnumber.pers productserialnumber.pers.old
Restart SMAS:
eCmd -c offline -entity=app -name=smisu4v
Wait for offline successful:
eCmd -c online -entity=app -name=smisu4v
If Standalone:
1. Rename the:
ProductSerialNumber.pers
A. Linux Standalone:
Path:
/opt/emc/SMAS/jboss/standalone/data/esrs/productserialnumber.pers
Command:
mv /opt/emc/SMAS/jboss/standalone/data/esrs/productserialnumber.pers productserialnumber.pers.old
B. Windows Standalone:
Path:
<Install_Dir>\SMAS\jboss\standalone\data\esrs\productserialnumber.pers
Rename using File explorer rename function.
2. Restart SMAS.
Affected Products
Unisphere for PowerMaxProducts
Secure Connect Gateway, CloudIQ, EMC Secure Remote Services, CloudIQ, Secure Connect GatewayArticle Properties
Article Number: 000195931
Article Type: Solution
Last Modified: 11 Jul 2024
Version: 5
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