Avamar: Windows File System backup fails with "fatal server connection problem" message

Summary: This Knowledge Base (KB) article that provides a solution for Avamar Windows File System backup failures due to connection errors.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

First-time backup of a Windows client fails with the following error messages in the log: 

avtar Info <5552>: Connecting to Avamar Server (DELL01)
avtar Info <5554>: Connecting to one node in each datacenter
avtar Info <6063>: - Communication error: Could not create connection to Server
avtar Info <5557>: No connections available
avtar FATAL <8604>: Fatal server connection problem, aborting initialization.   Specify correct server address and login credentials.
avtar FATAL <8941>: Failed to initiate connection with server due to earlier errors.   Verify server address and login credentials.
avtar Info <6149>: Error summary: 2 errors: 8604, 8941
avtar Info <8468>: Sending wrapup message to parent
avtar Info <5314>: Command failed (2 errors, exit code 10008: cannot establish connection with server (possible network or DNS failure))

Cause

The Avtar.exe process is unable to establish a connection to the Avamar Utility Node due to a domain naming system (DNS) resolution issue.

Resolution

  1. Verify that the Windows client can successfully resolve the Fully Qualified Domain Name (FQDN) of the Avamar Utility Node to its IP address. This can be accomplished using a DNS host A record on the DNS server that the client resolves to. Alternatively, edit the local hosts file (usually C:\Windows\System32\drivers\etc) and add the FQDN and IP address of the Avamar server.
  2. The issue may also be due to the "--hfsaddr" value in the mcserver.xml file pointing to the shortname rather than the FQDN of the Avamar grid. Avamar support should perform the following steps below:
    1. Correct the hfsaddr value in mcserver.xml to FQDN of the Avamar grid using Vi editor. The file is located in the "/usr/local/avamar/var/mc/server_data/prefs" directory on the Avamar server.
    2. Restart the Management Console Service (MCS) service by typing the following commands from KB article Avamar: How to Restart Management Console Server.
    3. Then retry the file system backup.
  3. If the above options do not resolve the issue, check the encryption mode if backing up to Data Domain. If it is set to "none", change it to "High" and then try the backup again.

Additional Information

Restarting the MCS service on the Avamar grid clears out the history of the backup jobs in the Activity Window of the Avamar Administrator.

Affected Products

Avamar Client for Windows, Avamar Server, Data Domain
Article Properties
Article Number: 000038622
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  5
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