PowerStore upgrade (NDU) to 3.2.x completed but Update Cluster Configuration failed to perform post upgrade commands

Summary: PowerStore: Upgrade succeeded. Failed to perform post upgrade commands: Encountered an exception while processing SupportAssist Enable command. (0xE04030010046) GUI shows: Upgrade succeeded. Failed to perform post upgrade commands: Encountered an exception while processing SupportAssist Enable command. (0xE04030010046) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

GUI shows:
Pre Stage Completed
Health Check Completed
Upgrade Completed
Commit Upgrade completed
Finalize Upgrade Pending
Update Cluster Configuration Completed
Update Database Pending
Cleanup Pending
Failed to perform post upgrade commands Support Assist Issue.PNG

Cause

The NDU completed and was committed successfully but failed during post upgrade commands while processing SupportAssist Enablement.

This is a timing issue which occurs during the updateLicenseAfterNDU stage when SupportAssist doesn't enable within the 15 second time limit.

Resolution

Workaround:
SupportAssist will normally enable successfully as part of the failed NDU process even though the time limit was exceeded.
Verify SupportAssist is enabled and then retry the NDU from the GUI and it should complete successfully.

Fix:
This issue will be fixed in a future code release.

If assistance is required please contact Dell Technical Support or your authorized service provider and reference this article.

Affected Products

PowerStore
Article Properties
Article Number: 000210341
Article Type: Solution
Last Modified: 20 Aug 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.