SupportAssist for Home PCs Displays Hardware Scan Warning in History
Summary:A hardware scan run in SupportAssist for Home PCs version 4.8.x reports a Warning status on the History page, but all hardware reports a Pass status.
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A Warning status may be seen on the History page in SupportAssist for Home PCs version 4.8.x when running a hardware scan. However, all individual hardware components report a Pass status and no issues are detected.
To validate this issue:
Open the History page in SupportAssist for Home PCs.
Verify that all individual scans report a status of Pass.
Confirm that there is no entry for a Battery test in the scan details.
Affected Software:
SupportAssist for Home PCs
Affected Version:
v4.8.x
Cause
This is a false positive warning that can be safely ignored. The issue occurs on desktop computers due to the absence of a laptop battery.
SupportAssist attempts to retrieve battery information as part of the scan. Since desktops do not have a laptop battery, the scan logs No device found for the battery check. This causes a Warning status in the scan summary, even though it is expected behavior for desktops.
Resolution
Note: Before starting the update, perform the following:
Back up all personal data. For more information, refer to Back Up and Recovery.
Connect the AC adapter if updates are being run on a laptop.