Avamar: SQL plugin - the second Incremental Backup is Promoted to FULL without a valid reason

Summary: Avamar SQL backups - the second Incremental Backup is Promoted to FULL without a valid reason.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When SQL full backups are completed, we can see the databases backup in FULL mode.

 

The first incremental backup completes without any issues, and we can see an incremental backup created.

2018-11-28 14:39:05 avsql Info <40401>: Only the LSN was verified, during log gap detection.

2018-11-28 14:39:05 avsql Info <14293>: Creating a database task for '(local)/DB/i-1.DB' (hcount 427)

 

However, the second incremental fails with log gap errors and gets promoted to FULL.

2018-11-28 14:35:16 avsql Info <15765>: A log gap was identified or a full backup was not found.

2018-11-28 14:35:16 avsql Warning <7420>: Forcing FULL backup for database '(local)/DB' due to the following reason: A log gap was identified or a full backup was not found.

 

In this case, a recent Full backup exists and no other backup tool was running incremental backups in between which could have broken the LSN (Log Sequence Number) and justified the "Log gap detection," therefore this "Promoted to FULL" operation has an invalid reason.

 

Cause

The Avamar algorithm to obtain the last Log Sequence Number (LSN) information was modified from 7.4 to 7.5. code which caused this issue to happen.

 

The engineering team has rectified this issue by providing a Hotfix that contains a change in the query of retrieving the last LSN of the databases.

 

Resolution

To resolve the Avamar SQL plug-in failures when the Second Incremental Backup is unexpectedly "Promoted to FULL," apply the following HFs or upgrade the Avamar client to a newer software release if it suits better:

v19.4.100-124    - HF#335861
v19.7.100-82     - HF#336118
v19.8 and above  - Fix already included into the code.

 

Follow this KB article to download the HF and remember to read the README file instructions before applying it:

  • KB 000212375 - Avamar: How to find and download a product hotfix, patch, install or upgrade package from the Dell Support website

 

Additional Information

  • Ensure that the impacted SQL databases are not recently restored databases.

 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000055465
Article Type: Solution
Last Modified: 11 Jun 2024
Version:  8
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