Avamar: SQL-laajennus – toinen lisäävä varmuuskopiointi ylennetään FULL-arvoon ilman pätevää syytä

Summary: Avamar SQL -varmuuskopiot – toinen lisäävä varmuuskopiointi ylennetään FULL-tilaan ilman pätevää syytä.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kun SQL-täydelliset varmuuskopiot on valmis, voimme nähdä tietokantojen varmuuskopioinnin FULL-tilassa.

 

Ensimmäinen lisäävä varmuuskopiointi suoritetaan ongelmitta, ja näemme, että lisäävä varmuuskopio luodaan.

2018-11-28 14:39:05 avsql Info <40401>: Only the LSN was verified, during log gap detection.

2018-11-28 14:39:05 avsql Info <14293>: Creating a database task for '(local)/DB/i-1.DB' (hcount 427)

 

Toinen inkrementaali epäonnistuu kuitenkin log gap -virheiden vuoksi, ja se ylennetään FULL-arvoon.

2018-11-28 14:35:16 avsql Info <15765>: A log gap was identified or a full backup was not found.

2018-11-28 14:35:16 avsql Warning <7420>: Forcing FULL backup for database '(local)/DB' due to the following reason: A log gap was identified or a full backup was not found.

 

Tässä tapauksessa on olemassa äskettäinen täydellinen varmuuskopio, eikä välissä ole suoritettu lisääviä varmuuskopioita, jotka olisivat voineet rikkoa LSN:n (Log Sequence Number) ja oikeuttaa "lokiaukon tunnistukseen", joten tällä "Ylennetty FULL" -toiminnolla on virheellinen syy.

 

Cause

Avamar-algoritmia, joka hakee viimeiset lokin järjestysnumerotiedot (LSN), muutettiin versiosta 7.4 versioon 7.5. koodi, joka aiheutti tämän ongelman.

 

Suunnittelutiimi on korjannut tämän ongelman toimittamalla hotfix-korjauksen, joka sisältää muutoksen tietokantojen viimeisen LSN:n noutamista koskevaan kyselyyn.

 

Resolution

Voit ratkaista Avamar SQL -laajennuksen epäonnistumisen, kun toinen lisäävä varmuuskopio siirretään yllättäen FULL-tilaan, ottamalla käyttöön seuraavat HF:t tai päivittämällä Avamar-asiakasohjelman uudempaan ohjelmistoversioon, jos se sopii paremmin:

v19.4.100-124    - HF#335861
v19.7.100-82     - HF#336118
v19.8 and above  - Fix already included into the code.

 

Lataa HF tämän tietämyskannan artikkelin avulla ja muista lukea README-tiedoston ohjeet ennen sen asentamista:

  • KB 000212375 – Avamar: Tuotteen hotfix-korjauksen, korjaustiedoston, asennuksen tai päivityspaketin etsiminen ja lataaminen Dellin tukisivustosta

 

Additional Information

  • Varmista, että kyseiset SQL-tietokannat eivät ole äskettäin palautettuja tietokantoja.

 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000055465
Article Type: Solution
Last Modified: 11 Jun 2024
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.