Dell Unity: Unable to Create DHSM Connection due to Invalid CTA Server Hostname

Summary: Resolve Unity Distributed Hash Table Secure Manager (DHSM) connection creation issues (Error Code: 0x6720642) caused by invalid Cloud Tiering Appliance (CTA) server hostname characters, such as underscores, and ensure valid hostname formatting for successful DHSM connection creation. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A DHSM connection cannot be created between Unity and CTA server. This error is seen when attempting to create the connection from the CTA server:

ACD authentication: Failed. No matching connection was found for the secondary target.  The connection will be created automatically after the first archiver run involving this primary and secondary.  If you want to verify the authentication credentials you must create a secondary connection for the primary on the control station.

Cause

The URL (hostname) of the CTA server contains an invalid character, such as an underscore.

Resolution

Change the hostname of the CTA to a valid name. In this case, a valid name was reached by removing the underscore. 

Example:
Original hostname: cta01_abc.xxxxx.com

Updated hostname: cta01abc.xxxxx.com
See the Additional Info section for which logs indicate the error in this example.

Additional Information

This error is seen when attempting to create the connection from the Unity CLI:
uemcli -u admin -p xxxxxxxx /net/nas/dhsmconn create -fs fs_2 -secondaryUrl http://cta01_abc.xxxxx.com/fmroot -secondaryUsername dhsm -secondaryPassword yyyyyyyy -secondaryPort 9000
Storage system address: 127.0.0.1
Storage system port: 443
HTTPS connection
Operation failed. Error code: 0x6720642
A create operation for a DHSM connection failed. (Error Code:0x6720642)
Job ID = N-7067
Unity SP logs show these entries:
B 02/01/19 17:50:10.992 MnsvcServer 7d8 [INFO] Authentication: Authentication session Session_103_1543000313: User admin successfully authenticated in authority LocalDirectory/Local
B 02/01/19 17:50:10.993 MnsvcServer 7da [INFO] Authentication: Authentication session Session_103_1543000313 succeeded: Principal User admin LocalDirectory/Local
B 02/01/19 17:50:10.994 CASAuth 560001 [INFO] Audit: Authentication successful.Username: admin ClientIP: 10.xx.xx.xx.
B 02/01/19 17:50:12.864 mlu 16f8500 [INFO] System: Request to create DHSM connection 0x2800000007 completed successfully.
A 02/01/19 17:50:12.875 mlu 12d0006 [INFO] System: CBFS_CREATE_DHSM_CNX request FAILED on 4000000001 completed with status 0x2..
A 02/01/19 17:50:12.885 mlu 16f8502 [ERROR] System: Failed to create a DHSM connection to http://cta01_abc.xxxxx.com/fmroot on file system 0x2800000007 of NAS server 0x1800000003.
B 02/01/19 17:50:13.349 mlu 16f8501 [INFO] System: Request to destroy DHSM connection 0x4000000040 completed successfully.
A 02/01/19 17:50:36.320 mlu 16f0020 [INFO] System: Request received to modify CIFS server modify VDM CIFS service status from UAPI.
A 02/01/19 17:50:36.329 mlu 16f0021 [INFO] System: Request to modify CIFS server 0x1C00000002 completed successfully.
Unity ktrace logs show these entries:
A 02/04/19 20:07:10.181 sade f069d705 c4_safe_ktrace CBFS: 6:[POC-CIFS] ready_start: 'connect fsid=536870922 type=HTTP rpolicy=2 http=http://cta01_abc.xxxxx.com/fmroot httpPort=90
A 02/04/19 20:07:10.181 sade f069d705 c4_safe_ktrace CBFS: 6:[POC-CIFS] 00 account='dhsm' passwd=******************** cgi=n timeout=30'
A 02/04/19 20:07:10.183 sade f069d706 c4_safe_ktrace DHSM: 3:[POC-CIFS] HTTP: Invalid character "_" in hostname "cta01_abc.xxxxx.com"
A 02/04/19 20:07:10.183 ade f069d706 c4_safe_ktrace DHSM: 3:[POC-CIFS] The host name in the secondary url cta01_abc.xxxxx.com is either missing formatted incorrectly.

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family
Article Properties
Article Number: 000057266
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.