PowerStore: Password reset and recovery for admin and service accounts
Summary: This article describes how to reset the admin or service account on PowerStore X and PowerStore T appliances.
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This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The method to reset these passwords depends on whether your appliance is a PowerStore T model or a PowerStore X model. Use the method that corresponds to your appliance to reset the admin or service, or both passwords.
Cause
The appliance ships with a default admin user account that can perform the initial configuration. It also ships with a default service user account that performs specialized service functions. It is recommended to initially configure PowerStore using the PowerStore Manager UI rather than another method such as the REST API or the CLI. Using the PowerStore Manager UI ensures that all the default passwords are changed. If the new passwords are forgotten, reset the passwords back to their default values.
Resolution
The procedure provided below was generated from the PowerStore: Security Configuration Guide
See the PowerStore Security Configuration Guide for the most up-to-date recommendations.
Procedures:
Resetting admin password for PowerStore T modePowerStore: Password reset and recovery for admin and service accountsl running PowerStoreOS 2.1 or later
Resetting admin password for PowerStore T model rPowerStore: Password reset and recovery for admin and service accountsunning PowerStoreOS 2.0 and earlier
Resetting admin password for PowerStPowerStore: Password reset and recovery for admin and service accountsore X model
Resetting admin password for PowerStore T model rPowerStore: Password reset and recovery for admin and service accountsunning PowerStoreOS 2.0 and earlier
Resetting admin password for PowerStPowerStore: Password reset and recovery for admin and service accountsore X model
Resetting admin password for PowerStore T model running PowerStoreOS 2.1 or later
For a PowerStore T model appliance, this procedure is the only way to reset the password if the admin password is forgotten or unknown. This procedure resets both the service and admin passwords to their respective default values.
Steps:
NOTE: To reset the password when the appliance is in Service Mode, use the following steps with one difference. Apply the USB reset process to each node. This action ensures that when the system is returned to Normal Mode. Upon PowerStore Manager login, a prompt is displayed to provide a new password for both the admin and service users.
Steps:
- Locate the nonmaskable interrupt (NMI) button for the node at the rear of the appliance. Find the button on the embedded module of the node, inside a small hole marked by two vertically aligned triangles pointing at each other
NMI button location on Embedded IO Modules
- Using a thin non-metallic object, press and holding the NMI button for only 1 - 2 seconds, then release it.
NOTE: Be careful. Pressing the NMI button for more than ten s resets (reboots) the node. Also, do not attempt another NMI password reset on the same node within two minutes.
- Connect to the PowerStore T model appliance using a browser to the management IP address and log in as admin with the default initial password Password123#. You should receive a prompt to reset both admin and service passwords.
- Change the admin password from the default to a user specified password. Clear the checkbox to set the service account password to be different from the admin password.
NOTE: If not prompted to reset the password upon login, repeat steps 1-4 on the other node. Act only if not prompted to reset the password on the first attempt. If still not prompted to reset the password on each login attempt after trying once on each node, contact your service provider.
Resetting admin password for PowerStore T model running PowerStoreOS 2.0 and earlier
A USB Thumb drive is required for resetting the Admin account password. Supported file systems include FAT32 and ISO 9660. USB port functionality will be removed in a future PowerStoreOS version.
NOTE: To reset the password when the appliance is in Service Mode, use the following steps with one difference. Apply the USB reset process to each node. This action ensures that when the system is returned to Normal Mode. Upon PowerStore Manager login, a prompt is displayed to provide a new password for both the admin and service users.
Steps
- If the USB drive is formatted, go to the next step; otherwise, use a command prompt such as: format <d:> /FS:FAT32 to format the drive. Where d: is the drive letter for the USB drive that was inserted into your laptop or personal computer.
- Set the label with the command:
label d: RSTPWD
The appliance does not mount the USB drive without the RSTPWD label. After labeling the USB drive, insert an empty file for the account passwords that can be reset from Command Prompt. Reset the admin or service account password, or both.
- To create an empty file on the drive, use one or both of the following commands as needed, On the USB-connected appliance open the Command Prompt and enter into the d:\ (pen drive-connected letter) and run these below commands to create the files on the USB.
copy NUL d:\admin
copy NUL d:\service - Insert the USB drive into the USB port of either node of the appliance, wait 10 s, and then remove it. The password for each account reset is now the default value.
- Connect to the cluster through a browser using the cluster IP address and log in as admin with the default initial password, which is Password123#. A prompt to reset the admin or service passwords, or both should appear. If preferred, reset the service password using secure shell (SSH), the initial default password for the service account is service.
- Change the admin password from the default to a user specified password. Clear the checkbox to set the service account password to be different from the admin password.

Resetting admin password for PowerStore X model
For a PowerStore X model appliance, use an ISO image and mount it from vSphere. Pre-created image files can be downloaded from https://www.dell.com/support. A new image can be created from a Linux system using the following touch commands:
NOTE: This may be downloaded using
yum install -y mkisofs
mkdir iso touch iso/admin mkisofs -V RSTPWD -o reset.iso iso
Example ISO creation
[root@computer tmp]# mkdir iso[root@computer tmp]# touch iso/admin [root@computer tmp]# mkisofs -V RSTPWD -o reset.iso iso |
NOTE:
- The ISO image, reset.iso, must reside on a datastore before it can be mounted as a virtual CD from vSphere.
- To reset the password when the appliance is in Service Mode, use the following steps with two differences.
- First: Upload the ISO image to the PRIVATE-XXXXXXX.A.INTERNAL datastore of the controller virtual machine (VM) itself because the public datastore is not available.
- Second: Upload and apply the reset.iso file to both controller VM nodes A and B. This action ensures that when the appliance is back in Normal Mode and PowerStore Manager access is available, a prompt to provide a new password for both the admin and service users.
Steps
- In vSphere under Storage, select your PowerStore X model appliance. For example, DataCenter-WX-D6013 > PowerStore D6013
- Under Files, select ISOs.
- Select Upload to upload the reset.iso file, either the precreated image file from www.dell.com/support or your own image file that was created on a Linux system. The reset.iso file appears in the ISOs folder.

- In vSphere under Host and Clusters, select the primary node of the primary PowerStore X model appliance in the cluster. For example, select DataCenter-WX-D6013 then Cluster WX-D6013 and then PSTX-44W1BW2-A
- Under Summary, click CD/DVD drive 1 and select Connect to datastore ISO file. The "Choose an ISO image to mount" window appears.
- Under Datastores, click the primary PowerStore X model appliance in the cluster and select the ISOs folder. The reset.iso file should appear under Contents.

- Select the reset.iso file and click OK. Under Summary, CD/DVD drive 1 should appear as Connected for about 10 s, and then change to Disconnected. The cluster admin password, or service password, or both, are now reset to their default.

- Connect to the cluster through a browser using the cluster IP address and log in as admin with the default initial password, which is Password123#. A prompt to reset the admin or service passwords, or both should appear. To reset the service password using SSH, the initial default password for the service account is service.

- Change the admin password from the default to a user specified password. Clear the checkbox to set the service account password to be different from the admin password.

Affected Products
PowerStoreArticle Properties
Article Number: 000125384
Article Type: Solution
Last Modified: 27 Jun 2025
Version: 13
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