PowerStore: Import of volume from PS array fails with "Import failed because access permissions on the source volume could not be set:"
Summary: This article details the issue and resolution when import of volume from PS array fails with "Import failed because access permissions on the source volume could not be set:" message
Symptoms
The issue outlined in this article applies to the maximum number of policies (4) that can be applied to a PS EqualLogic volume. If the maximum number of policies is reached, then the PowerStore Import fails with the above failure. An alert is then generated stating that the "Operation on import session <session_name> has failed with errors on the source side."
The details of the "Failed" Import session, as seen in PowerStore Manager > Migration > Import External Storage > IMPORTS > Failed, shows the Failure Reason:
"Import failed because access permissions on the source volume could not be set:error in setting volume permissions as Maximum number of access policies and policy group associations to this volume reached."
Cause
The PowerStore Import of a volume from the PS source array failed because the source array had the maximum of four (4) policies already applied to the volume. The Import session will fail if four (4) policies are already applied to imported volumes.
Resolution
Solution
1. Identify the name of one or more Import volumes that failed.
2. Verify the number of policies associated with the volume on the source PS array:
3. If the number of group or individual policies shown has reached the maximum of four (4), remove one of the policies.
acl access-policy-group select <access_policy_group_name> disassociate-from <volume_name>
4. Go to PowerStore Manager > Migration > Import External Storage > select array, then IMPORT STORAGE > select volume, then REFRESH ACTIONS > Refresh Hosts and Refresh Volumes, then retry the Import operation.