PowerEdge: iDRAC IPMI over LAN connections fail after importing Server Configuration Profile

Summary: This Dell EMC article provides step-by-step guidance on how to resolve the issue when iDRAC stops accepting remote IPMI commands after importing iDRAC User attributes with "Password Hash Values" feature enabled. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Description

iDRAC may stop accepting remote IPMI commands after importing iDRAC User attributes with "Password Hash Values" feature enabled.
 

ipmitool -I lanplus -H 192.168.10.3 -U root -P calvin sdr elist
Error: Unable to establish IPMI v2 / RMCP+ session
Device not present (No Response)


Dell EMC iDRAC added support for importing iDRAC User passwords through HASH and Salt value pairing. This feature adds an additional layer of security when importing iDRAC User Accounts. There are several common methods of exporting and importing iDRAC User passwords with Hash Passwords that may lead to this behavior:
 

  • Server Configuration Profile export/import (optional)
  • RACADM CLI iDRAC User creation with HASH password (optional)
  • Redfish CLI iDRAC User creation with HASH password (optional)
  • Easy Restore feature after system motherboard replacement (optional)

Cause

Dell EMC iDRAC9 introduced a new feature to mask clear text user passwords with the initial introduction of the product. When leveraging salted hash values for iDRAC user passwords, Dell OEM IPMITOOL is required to parse the hashed password value.  

Resolution

Solution

The "Password Hash Values" feature requires a supported version of the Dell EMC IPMItool to properly handle the encrypted HASH password. For support of HASH Password encryption, please use the Dell EMC IPMITOOL versions bundled within the following BMC Toolsets at a minimum:
 


Dell EMC's changes to the IPMItool have been submitted to the Open Source Community. Some Linux distributions may leverage newer versions of IPMItool that do not yet support this change.

Recovery:

If HASH passwords have been applied to an iDRAC User Account inadvertently, overwriting the user password using clear text allows third-party IPMI tools to reconnect.

  • iDRAC GUI >> iDRAC Settings >> Users >> Edit
    iDRAC User  Configuration settings 
  • racadm set iDRAC.Users.X.Passowrd xxxxxxxxxxx
    /admin1-> racadm set iDRAC.Users.16.Password Dell1234
    [Key=iDRAC.Embedded.1#Users.16]
    Object value modified successfully
    /admin1->

Affected Products

iDRAC9

Products

PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515 , PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000178105
Article Type: Solution
Last Modified: 05 Dec 2024
Version:  6
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