PowerEdge: iDRAC IPMI over LAN connections fail after importing Server Configuration Profile
Summary: This Dell EMC article provides step-by-step guidance on how to resolve the issue when iDRAC stops accepting remote IPMI commands after importing iDRAC User attributes with "Password Hash Values" feature enabled. ...
Symptoms
Description
iDRAC may stop accepting remote IPMI commands after importing iDRAC User attributes with "Password Hash Values" feature enabled.
ipmitool -I lanplus -H 192.168.10.3 -U root -P calvin sdr elist
Error: Unable to establish IPMI v2 / RMCP+ session
Device not present (No Response)
Dell EMC iDRAC added support for importing iDRAC User passwords through HASH and Salt value pairing. This feature adds an additional layer of security when importing iDRAC User Accounts. There are several common methods of exporting and importing iDRAC User passwords with Hash Passwords that may lead to this behavior:
- Server Configuration Profile export/import (optional)
- RACADM CLI iDRAC User creation with HASH password (optional)
- Redfish CLI iDRAC User creation with HASH password (optional)
- Easy Restore feature after system motherboard replacement (optional)
Cause
Dell EMC iDRAC9 introduced a new feature to mask clear text user passwords with the initial introduction of the product. When leveraging salted hash values for iDRAC user passwords, Dell OEM IPMITOOL is required to parse the hashed password value.
Resolution
Solution
The "Password Hash Values" feature requires a supported version of the Dell EMC IPMItool to properly handle the encrypted HASH password. For support of HASH Password encryption, please use the Dell EMC IPMITOOL versions bundled within the following BMC Toolsets at a minimum:
Windows | ipmitool version 1.8.14.dell47| Dell EMC OpenManage BMC Utility,v9.1.0Linux | ipmitool version 1.8.14.dell51| Dell EMC iDRAC Tools for Linux, v9.3.0
Dell EMC's changes to the IPMItool have been submitted to the Open Source Community. Some Linux distributions may leverage newer versions of IPMItool that do not yet support this change.
Recovery:
If HASH passwords have been applied to an iDRAC User Account inadvertently, overwriting the user password using clear text allows third-party IPMI tools to reconnect.
- iDRAC GUI >> iDRAC Settings >> Users >> Edit
racadm set iDRAC.Users.X.Passowrd xxxxxxxxxxx
/admin1-> racadm set iDRAC.Users.16.Password Dell1234
[Key=iDRAC.Embedded.1#Users.16]
Object value modified successfully
/admin1->