NetWorker VMware workflows fail to load inventory as Sessions Count is limited
Summary: NetWorker VMware group with Dynamic Association failing with error "Sessions count is limited"
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Symptoms
NetWorker VMware group with Dynamic Association failing with error "Sessions count is limited to <Number>. Existing sessions are <Number>
NetWorker workflows associated with Group Type: VMware and has Dynamic Association enabled (Tag based association), fails with error "Failed to load inventory". Detailed error below:
NetWorker workflows associated with Group Type: VMware and has Dynamic Association enabled (Tag based association), fails with error "Failed to load inventory". Detailed error below:
Inventory session status returned with a failure. Error: 'Failed to load inventory from '<vCenter name>'. Failed to load Category/Tagging metadata. Failed to login to CIS service at 'HTTPS://<vCenter name>/rest/com/vmware/cis/session'. A 'POST' method to CIS service at 'HTTPS://<vCenter name>/rest/com/vmware/cis/session' responded with code 503: Error from CIS service: 'Sessions count is limited to 3000. Existing sessions are 3000.%!(EXTRA string=3000, string=3000)''.
Workflows start normally when restarted after a period of time.
Cause
This issue is seen when the VMware API sessions are set to 3000 and the vCenter has already accepted 3000 sessions at the time of the Inventory call by NetWorker.
Resolution
Contact the VMware administrator to increase the number of RestAPI sessions on the vCenter. With this change, the VMware administrator should also plan to increase the memory allocated to vAPI endpoints.
Affected Products
NetWorker FamilyArticle Properties
Article Number: 000184075
Article Type: Solution
Last Modified: 02 Nov 2021
Version: 3
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