ECS: GeoDrive experiences performance issues
Summary: Troubleshooting GeoDrive slow performance and timeout errors
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Slow performance identified when archiving to the ECS using Geo Drive on Windows Storage Server.
- Also noticed 404 errors for requests on ECS.
Cause
A possible cause is a very large change-log found for each cloud-drives. The change log contains things like permission, attribute changes, file/folder deletes, folder creates, file renames. It is a first-in/first-out queue that must preserve the ordering of operations. If the count of the change log is huge, that causes performance issues.
Resolution
Resolution:
For all Geodrive Versions:
Find the size of the change log and if huge, disable it from saving file security/description in cloud server:
For all Geodrive Versions:
Find the size of the change log and if huge, disable it from saving file security/description in cloud server:
- From the screenshot over on the right in the Activity Window, it shows the size of the change log for each of the cloud drives.
- Right-click on the cloud drives, go to Settings, and checkmark "DO not save file security/description in cloud server". Click “OK”
Affected Products
GeoDrive for Windows, Elastic Cloud StorageArticle Properties
Article Number: 000194162
Article Type: Solution
Last Modified: 02 Feb 2022
Version: 2
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