NetWorker Virtualization: vProxy File Level Recovery Restore fails with Error: Unable to create NFS export...responded with code 400

Summary: Doing a vProxy file level recovery (FLR) restore fails with error: A 'POST' method to DataDomain at 'https://prod6300.canstockta.com:3009/rest/v2.0/dd-systems/0/protocols/nfs/exports' responded with code 400: Error from DataDomain: **** Failed to validate client list, duplicate client entry specified: code 5008. ...

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Symptoms

Error message:

159373:nsrvproxy_flr: vProxy Log: 2022-03-07T20:27:47Z ERROR: [241] Unable to create NFS export.
159373:nsrvproxy_flr: vProxy Log: 2022-03-07T20:27:47Z INFO: [241] Unmounting after mount failure: Unable to create NFS export at 'prod6300dd.canstockta.com:/data/col1/cstnwkrmo/FLR-vproxy03-747125fa-d596-4423-9f02-a2431378313a': Unable to create NFS export. A 'POST' method to DataDomain at 'https://prod6300.canstockta.com:3009/rest/v2.0/dd-systems/0/protocols/nfs/exports' responded with code 400: Error from DataDomain: '**** Failed to validate client list, duplicate client entry specified: <Client_IP> code 5008'


Location: Go to NMC > Recover tab > Select the vProxy you tried to Restore > Open > Copy the entire logs and paste in to a notepad file.

Cause

FLR is failing because vProxy is configured with two NICs and both are assigned to the same IP address. As part of the FLR process, Data Domain is creating an NFS export path. We are providing the same IP address twice to the Data Domain to include it in the list of clients that can access the NFS export. Using the same IP address on both NICs for the vProxy is an unsupported configuration. This is causing the Data Domain to error out due to the duplicate IP address on both NICs.

Resolution

Resolution:
Confirm if the vProxy is multi-NIC, and if the same IP address is assigned to two different NICs.

Note: The "ip addr" command shows the IP addresses assigned to each NIC.

  • Option A:

Redeploy the vProxy and use a unique IP address for each NIC.

Or
 

  • Option B:

Assign a different IP for the second NIC on the vProxy having this issue.


Workaround:
Select disconnect for the second vProxy, select another vProxy (such as vProxy02), edit the settings, and when it is showing as disconnected, retrigger the FLR Restore. The Restore should be successful as there are no conflicts.

Additional Information

  • It is recommended to leave the Export path blank, which sets the export path to the default MTree path.
  • The short name of the NetWorker server in lower case is the default path. 
  • If using a different Export path, ensure the MTree path exists on the Data Domain file system.

Before proceeding with the workaround, ensure:

  •  The Data Domain management credentials are mandatory for the FLR and instant recovery in the devices section.

Note: Follow the below Dell kb article 26710: NVP-vProxy: FLR recovery fails to mount the backup image with error: Management credentials for setting up export path were not configured (Log in by registered users on Dell Support is required to view this article.)

  •  Check if there is proper communication among vProxy, Data Domain, and ESXI hosts.

Note: Follow page 18 in the below Networker documentation to check communication requirements: 

https://dl.dell.com/content/docu104870_networker-19-5-vmware-integration-guide.pdf?language=en-us

Affected Products

NetWorker Family
Article Properties
Article Number: 000197446
Article Type: Solution
Last Modified: 05 Sep 2023
Version:  2
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