Symptoms
Un système de fichiers qui ne manque pas d’espace en termes de capacité est en panne d’inodes et ne peut pas effectuer de nouvelles écritures.
Pour ce problème, aucune erreur ne s’affiche dans l’interface utilisateur de PowerStore Manager et aucune alerte n’est créée pour le système de fichiers en question.
Les quotas d’utilisateur et d’arborescence ne sont pas dépassés non plus.
Les messages d’erreur du côté client peuvent inclure, sans s’y limiter:
mkdir: cannot create directory 'DirectoryName': Invalid argument |
La vérification de l’espace libre à l’aide de df -h peut toujours signaler l’espace libre sur le partage de fichiers, mais df -i affiche l’utilisation de l’inode du partage.
Dans cet exemple, PowerStoreShare1 dispose d’un grand nombre d’inodes libres, mais PowerStoreShare2 est hors des inodes.
[user@ ~]$ df -i Filesystem Inodes IUsed IFree IUse% Mounted on ... NAS_Server:/PowerStoreShare1 16889584 35 16889549 1% /MountPath1 NAS_Server:/PowerStoreShare2 16889584 16889584 0 100% /MountPath2 |
Cause
Le système de fichiers peut manquer d’inodes et n’autorise plus les écritures sur le système de fichiers.
Un inode représente les métadonnées utilisées pour la structure de répertoires de fichiers et de dossiers.
Cela n’est pas directement lié à la capacité (espace) utilisée.
Selon le modèle d’utilisation, les inodes peuvent être utilisés, et PowerStoreOS version 2.1 et antérieures peut ne pas être en mesure de réaffecter les inodes libérés pour d’autres écritures.
Resolution
Correction
Ce problème est résolu dans PowerStoreOS versions 3.0 et ultérieures.
Solution de contournement :
Augmentez la taille du système de fichiers. L’allocation d’inodes est automatique et se produit en fragments de 256 Mo. Il suffit généralement d’augmenter l’espace du système de fichiers de quelques Go.
Une fois l’accès en écriture restauré, le système de fichiers peut être réduit à nouveau à la taille d’origine.
Si l’augmentation de la taille du système de fichiers ne résout pas le problème, contactez le support technique Dell ou votre représentant de service agréé et indiquez l’ID de cet article de la base de connaissances.