Symptoms
System plików, w przypadku których nie ma miejsca pod względem pojemności, nie jest w stanie wykonać nowych zapisów.
W przypadku tego problemu w interfejsie użytkownika PowerStore Manager nie jest wyświetlany żaden błąd i nie jest tworzony żaden alert dla danego systemu plików.
Limity użytkowników i drzew nie są przekraczane.
Komunikaty o błędach po stronie klienta mogą obejmować między innymi:
mkdir: cannot create directory 'DirectoryName': Invalid argument |
Sprawdzanie wolnego miejsca przy użyciu polecenia df -h może nadal zgłaszać wolne miejsce w udziale plików, jednak df -i pokazuje wykorzystanie węzła udziału.
W tym przykładzie powerStoreShare1 ma mnóstwo bezpłatnych wędów, jednak PowerStoreShare2 jest poza węzłami.
[user@ ~]$ df -i Filesystem Inodes IUsed IFree IUse% Mounted on ... NAS_Server:/PowerStoreShare1 16889584 35 16889549 1% /MountPath1 NAS_Server:/PowerStoreShare2 16889584 16889584 0 100% /MountPath2 |
Cause
W systemie plików mogą występować węzły i nie można już zapisać w systemie plików.
Inode oznacza metadane używane w strukturze katalogu plików i folderów.
Nie jest to bezpośrednio związane z używaną pojemnością (miejscem).
W zależności od wzorca użytkowania węzły mogą być używane, a system PowerStoreOS w wersji 2.1 i starszych może nie być w stanie zmienić przeznaczenia uwolnionych węzłów w celu dalszych zapisów.
Resolution
Rozwiązanie
Ten problem został rozwiązany w systemie PowerStoreOS w wersji 3.0 i nowszych.
Obejście problemu:
Zwiększ rozmiar systemu plików. Alokacja wodów jest automatyczna i występuje we fragmentach 256 MB. Zazwyczaj wystarczy zwiększyć ilość miejsca w systemie plików o kilka GB.
Po przywróceniu dostępu do zapisu system plików może zostać ponownie zmniejszony do pierwotnego rozmiaru.
Jeśli zwiększenie rozmiaru systemu plików nie rozwiąże problemu, skontaktuj się z działem pomocy technicznej firmy Dell lub autoryzowanym przedstawicielem serwisu i podaj ten identyfikator artykułu bazy wiedzy.