SourceOne Discovery Manager Web: Summary of collection search when printed does not display all the folders under "Executions" section.
Summary: Not all the folders displayed under the "Executions" section gets printed while printing the summary of the collection search.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
If a SourceOne Discovery Manager Web user selects a collection search which involved large number of folders, navigates to "Summary" tab, expands "Executions" section and selects "Print" button, folder list on print page is truncated which was present under "Executions" section.
This issue is seen when a large number of mapped folders are selected for collection search.
This issue is seen when a large number of mapped folders are selected for collection search.
Cause
This issue is caused by a software defect.
Resolution
This issue will be resolved in patches or Service Pack versions of SourceOne Discovery Manager post 7.2.SP12 (7.2.12.0021). DELL EMC SourceOne Patch and Service Pack kits are available for download through https://www.dell.com/support/.
- Navigate to folder where SourceOne Discovery Manager Web is installed and go to "\DiscoveryManagerWeb\Scripts\packages\DiscoveryManager" subfolder.
- Copy "all.js" to a safe location as backup.
- Edit "all.js" file and look for the following section:
this._toPrintView();
domStyle.set(content.domNode.id, "width", "80em");
- Modify the identified section and change "80em" to "". The following is an example:
this._toPrintView(); domStyle.set(content.domNode.id, "width", "");
- Save changes to the "all.js" file and close it.
- Start the command prompt as an administrator and run "
IISreset /noforce" command.
Additional Information
Note:
- In some rare cases due to browser cache user may experience an original issue, it is recommended to test in "Incognito" mode of the browser or using another host computer.
- In case the folders count is very large and the user is looking to print, the default paper size of "Letter" or "A4" may not be enough to accommodate all the folders listed on summary page although the new print window after the fix is displaying all the folders. In such cases the user will have to either select large page size, e.g., A3 or use options that allow shrinking content to fit to the paper size selected. Not all printers and drivers settings allow content to be shrunk to fit to page size.
Affected Products
SourceOne, SourceOne Discovery Manager, SourceOne Email ManagementArticle Properties
Article Number: 000198667
Article Type: Solution
Last Modified: 02 Jun 2025
Version: 7
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