PowerEdge: Data Retention Occur with SSD or Nvme Drives Due to Prolonged Power off
Summary: Systems containing an enterprise SSD or NVMe device which are powered off for a duration of more than 3 months may exhibit errors or drive faults due to data retention limitations within the device. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Enterprise SSD and NVMe drives retain data within their NAND structure by using voltage levels which represent the stored data. This enables the drives to have many beneficial features such as high read and write speeds and low-latency. However, it also requires that these voltages are maintained for as long as the data is required to be stored. Drive firmware performs background tasks to maintain data consistency as part of its "data retention" feature-set.
Cause
SSD and NVMe devices which are powered-up carried out data retention tasks to refresh the static voltages within the NAND cells. Also, NAND wear-leveling is optimized and is performed whether the drives are idle or undergoing host I/O operations.
In contrast, drives which are powered off for extended durations cannot carry out these data retention operations. Under certain circumstances, drives may be prone to reduced NAND cell voltages within the retained data which may lead to media or drive faults on resumption of operation.
In contrast, drives which are powered off for extended durations cannot carry out these data retention operations. Under certain circumstances, drives may be prone to reduced NAND cell voltages within the retained data which may lead to media or drive faults on resumption of operation.
Resolution
The JEDEC SSD Standards JESD218 & JESD219 provide industry-wide requirements around data retention for SSD media.
The standard requires SSD/NVMe drives to retain their data during a power-off period for a minimum duration of three months at the maximum level of rated endurance (that is in a fully consumed state in terms of write-endurance).
It should be noted that data retention is negatively impacted by the following factors:
The standard requires SSD/NVMe drives to retain their data during a power-off period for a minimum duration of three months at the maximum level of rated endurance (that is in a fully consumed state in terms of write-endurance).
It should be noted that data retention is negatively impacted by the following factors:
- The P/E cycles and TBW state (remaining endurance) of the drive
- A drive which has had more P/E cycles or TBW have less retention capability than a new drive with few P/E cycles or TBW.
- Active temperature over the lifetime of the drive
- The temperature of the NAND cells over the lifetime of the drive impacts the retention capability.
- Power-off temperature over the duration of the power-off event
- Drives which are in a powered-off state should be stored at an ambient temperature not exceeding 40 degrees C / 104 degrees F.
Affected Products
Dell PowerEdge Express Flash NVMe PCIe SSD, PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge M7701, PowerEdge M7725, PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240
, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R6715, PowerEdge R6725, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R770AP, PowerEdge R7715, PowerEdge R7725, PowerEdge R7725xd, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640
...
Article Properties
Article Number: 000198930
Article Type: Solution
Last Modified: 02 Sep 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.