PowerStore: Cannot change Language Preference in GUI after Language Pack is installed
Summary: The user fails to change Language Preference in PowerStore Manager GUI after a Language Pack is installed.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
After Language Pack is installed, the user tries to change Language to the preference language (for example: Brazilian Portuguese) in GUI, and GUI shows the following errors, and the language is not changed:
This issue affects other languages as well.
Cause
The PowerStore Manager always detects the preferred language of the browser and uses that locale to load the files translation.json and branding.json. If a Language Pack is not installed, the PowerStore Manager tries to access translation.json and branding.json for that locale. The result is HTTP 404 as expected and the result is cached in CP server. The issue occurs when the CP cache is not cleared after the Language Pack is installed. As a result, after the Language Pack is installed, when the user attempts to change the Language to the preferred language of the browser, GUI still gets HTTP 404 when loading translation.json and branding.json in that locale which prevents GUI from changing the language.
Resolution
If this issue occurs, restart CP in a service container using “svc_container_mgmt” service script.
svc_container_mgmt restart CP
If the issue still occurs after CP is restarted when changing the language to the preferred language, clear the cache and cookies in the customer’s browser.
Additional Information
For more details on running svc_container_mgmt see Dell EMC PowerStore Service Scripts Guide.
Affected Products
PowerStoreArticle Properties
Article Number: 000202758
Article Type: Solution
Last Modified: 13 Jun 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.