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Unable to send data to CloudIQ in Unisphere for PowerMax

Summary: Customer is receiving an error 'Failed to process command: javax.ejb.EJBException Execution_Failed status 500' after checking box for send data to CloudIQ after registration of Unisphere for PowerMax (U4P) with the SRS GW. ...

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Symptoms

After registering embedded U4P with the SRS GW and selecting Send Data to CloudIQ in U4P an error appears 'Failed to process command: javax.ejb.EJBException Execution_Failed status 500'

When dialed into both containers on the array as root user some commands return with a message stating 'caller is not authorized the perform the requested operation' (e.g. symaudit -sid XXXX list). Local SMC user is listed as Admin in the symauth table on both containers so it should have the necessary permissions.


smas.log
2022-10-19 22:02:48,712 WARN  [em.bp.SECURITY] (default task-11) com.emc.em.domain.cirrus.CirrusEnrollment.isEnrollmentEnabled():Cirrus enrollment is disabled
2022-10-19 22:02:57,252 WARN  [em.spa.SPA] (master) SpaQueryDefAccess.startTimer.JVM 0:false:false:false:::0:0:0
2022-10-19 22:03:00,681 WARN  [em.bp.ESRS] (default task-35) com.emc.em.sage.esrs.ESRSCommandProcessor:Changing CloudIQ data collection details.
2022-10-19 22:03:01,005 WARN  [em.bp.SECURITY] (default task-35) com.emc.em.domain.cirrus.CirrusEnrollment.enrollWithCirrus():Attempt to enroll with Cirrus CIQ_COLLECTION by user XXXX. Enrollment is disabled.
2022-10-19 22:03:01,387 WARN  [em.bp.UTIL] (default task-35) SymapiCallTracer:InputArgs::SymVnetContainerShow failed with code 3596 (The specified object does not exist)



symapi log
10/24/2022 00:00:00.073  12309     26 EMC:UNIVMAX                check_user_perms     User Authorization Failure for User H:MGMT-0\smc, Group , SID 000XXXXXXXXX  -- 'VIEW' rights not present (minimum necessary role: Monitor)
10/24/2022 00:00:00.079  12309     26 EMC:UNIVMAX                SymSfsMkdir          Access Denied for User H:MGMT-0\smc, Group , access VIEW (minimum necessary role: Monitor)


collection log
2022-10-03 14:42:23,214 INFO [em.bp.ESRS] (default task-55) com.emc.em.domain.esrs.sfs.SfsFileXFer.ctor:using SFS directory of /CLOUDIQ_ESRS_FILES2 2022-10-03 14:42:23,243 WARN [em.bp.ESRS] (default task-55) Unable to create directory /CLOUDIQ_ESRS_FILES2 on array 000XXXXXXXXX: The caller is not authorized to perform the requested operation :Exception java.io.IOException of level ERROR repeated: 1584257354 2022-10-03 14:42:58,345 ERROR [em.bp.ESRS] (EE-ManagedScheduledExecutorService-collector-manager-Thread-29) ContextualEsrsService.init:Unable to process registration for array 000XXXXXXXXX: java.io.IOException: Unable to create directory /CLOUDIQ_ESRS_FILES2 on array 000XXXXXXXXX: The caller is not authorized to perform the requested operation


Cause

There were permission issues preventing the creation of directory, /CLOUDIQ_ESRS_FILES2, used for file transfer.  This will prevent the data from being sent after enabling Send Data to CloudIQ in Unisphere for PowerMax.

Resolution

Customer checked the Unisphere 360 Support check box in Unisphere and unregistered U4P with the SRS GW, waited 1 hour, re-registered U4P with the SRS GW and it connected and had no errors when checking the box for Send Data to CloudIQ.

In summary the steps to resolve the issue were:
1. In Unisphere go to Settings > Preferences > General > check Unisphere 360 Support.
2. Go to Settings > Mangement > Secure Remote Services and unregister Unisphere with the SRS GW.
3. Wait 1 hour.
4. Go to Settings > Mangement > Secure Remote Services and re-register U4P with the SRS GW.
5. Go to Settings > Mangement CloudIQ and check the Send data to CloudIQ for local systems check box.

Affected Products

CloudIQ, PowerMax 2000, Unisphere for PowerMax
Article Properties
Article Number: 000204792
Article Type: Solution
Last Modified: 23 Feb 2023
Version:  7
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