Zoom Virtual Background Does Not Work on Inspiron 14 3420 Laptop

Summary: The following article provides information about an issue with Virtual Backgrounds in the Zoom application. Zoom does not show the attendee when Virtual background is enabled on Inspiron 14 3420 Laptops. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Virtual Background in Zoom does not show the attendee

 

Your Inspiron 14 3420 laptop may experience a problem while using the virtual background filter in the Zoom application. (The filters are found by opening Settings and browsing to Background and Effects.)

Using the third-party video conferencing application shows the following symptoms:

  • Nobody that attends the video conference can see your face after applying the virtual background filter.
  • Those choosing the blur filter report that Zoom gives an error message and crashes.

Zoom Virtual Backgrounds screenshot

Zoom Error Message screenshot

Cause

The algorithm that Zoom uses for virtual backgrounds, and blur is not fully compatible with Advanced RISC Machine (ARM) laptops.

Resolution

The following two sets of steps resolve these two issues on your laptop.

To resolve the virtual backgrounds problem, follow these steps:

  1. Browse to the virtual backgrounds page in the Zoom application.

  2. Locate the option for I have a green screen and put a tick in the checkbox. 

    I have a green screen screenshot

  3. This allows the Zoom algorithm to identify your face.

To resolve the blur problem, follow these steps:

  1. Open the laptops settings window.

  2. Browse to devices and then Bluetooth and devices, before selecting Cameras.

  3. Enable the option for background effects.

    Camera Settings screenshot


Back to Top

Affected Products

Inspiron 14 3420
Article Properties
Article Number: 000204839
Article Type: Solution
Last Modified: 02 Oct 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.