Dell Unity: SRA File appliance not detecting the correct replication status - shows Failover in progress

Summary: Unity SRM/SRA plugin discover shows the status as "Failover in progress".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SRA command 'discover Arrays' fails with failover in progress.
Failover test fails with create snapshot.

Cause

Unity SRM/SRA plugin does not support subnet option for ESXi hosts discovery when using NFS data stores.
The ESXi hosts have to be explicitly added in the host entry using Unisphere ACCESS --> Hosts or add a Vcenter ACCESS --> VMware and import the hosts.

Dedicated SRA access account is required for SRM.

Resolution

Configuration needs to be corrected:
1. NAS server needs to have one production IP address and one backup IP address on both source and destination arrays with IP Override at the destination site.
2. File SRA does not support Traditional NFS shares, only VMFS (VMware Datastores), and must add individual host access. Currently, Subnet is not supported.
Another option is to add the Vcenter in the unity so that the ESX hosts are automatically imported, and the relevant host entries are added to access the NFS data stores.

3. "srmadmin" account on Unity must have "Administrator" privilege instead of "Storage  Administrator" as mentioned in the Dell EMC Unity: VMware Site Recovery Manager Best Practices  Page 14. This is mainly for performing the DR tests.

Note: This is relevant when Vcenter cannot be added in the Unity, and the ESXi hosts must explicitly be added manually.

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000214347
Article Type: Solution
Last Modified: 29 Aug 2023
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.