PowerScale: OneFS traci blokadę NFSv4 po ponownym uruchomieniu węzła

Summary: Klienci NFSv4 mogą utracić blokadę lub nie być w stanie prawidłowo zwolnić blokady po ponownym uruchomieniu węzła.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ten problem występuje we wszystkich wersjach OneFS przed rozwiązaniem problemu.
Może to wpłynąć na wszystkie aplikacje wykorzystujące NFSv4 i operacje blokowania.

Ten problem najczęściej występuje w przypadku aplikacji "Message Queue", takich jak ActiveMQ lub OpenMQ, ponieważ korzystają one z mechanizmów blokowania NFSv4.

W przypadku aplikacji MQ; Często przejawia się to przejęciem serwera MQ dla podstawowego, kiedy nie powinien.
Powoduje to przerwy w pracy lub niespójności danych, które wymagają ręcznej interwencji po stronie aplikacji w celu rozwiązania problemu.

W przypadku przechwytywania pakietów klient blokuje plik pomyślnie, podczas gdy drugi klient próbuje uzyskać do niego dostęp.
Po podłączeniu klienta blokującego do ponownego uruchomienia drugi klient otrzymuje blokadę.
Pierwszy klient otrzymuje błąd po zakończeniu blokady, ponieważ nie ma już blokady.

Problem można odtworzyć w następujący sposób:

  1. Na pierwszym kliencie zamontuj eksport przy użyciu NFSv4.0.
  2. Na drugim kliencie zamontuj ten sam eksport przy użyciu NFSv4.0.
  3. Na pierwszym kliencie zablokuj plik na 5 minut.
  4. Na drugim kliencie rozpocznij pętlę, próbując zablokować ten sam plik.
  5. Uruchom ponownie węzeł OneFS, do który jest podłączony pierwszy klient.
  6. Jeśli problem występuje, drugi klient otrzymuje blokadę przed zakończeniem pierwszej blokady klienta.

 

Cause

Wystąpił błąd w naszej logice przenoszenia połączeń NFSv4 do innych węzłów, który powodował zwolnienie blokady przy ponownym uruchomieniu węzła.

 

Resolution

Naprawić:
Uaktualnij lub załaduj do jednej z następujących wersji OneFS.

  • 9.1.0.19+
  • 9.2.1.12+
  • 9.4.0.3+
  • 9.5.0.0+

Obejście:
Nie ma obejścia tego problemu.

 

Affected Products

PowerScale OneFS
Article Properties
Article Number: 000215804
Article Type: Solution
Last Modified: 26 Sep 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.