PowerScale: OneFS förlorar NFSv4-lås vid nodomstart

Summary: NFSv4-klienter kan förlora lås eller inte släppa lås korrekt efter omstart av noden.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Problemet förekommer i alla OneFS-versioner innan utveckling kan åtgärdas.
Det kan påverka alla program som använder NFSv4 och låsningsåtgärder.

Det här problemet har oftast observerats med "Meddelandekö"-program som ActiveMQ eller OpenMQ eftersom de använder NFSv4-låsningsmekanismer i stor utsträckning.

För MQ-program; visas ofta som en sekundär MQ-server som tar över för den primära om den inte gör det.
Det leder till avbrott eller datainkonsekvenser som kräver manuella åtgärder på programsidan för att lösa problemet.

När det observeras i paketinsamlingar låser klienten en fil medan en andra klient försöker komma åt den.
När den nod som låsklienten är ansluten till startas om beviljas den andra klienten låset.
Den första klienten får ett felmeddelande när låset upphör eftersom de inte längre har låset.

Problemet kan återskapas enligt följande:

  1. På den första klienten monterar du en export med NFSv4.0.
  2. På den andra klienten monterar du samma export med NFSv4.0.
  3. På den första klienten låser du en fil i 5 minuter.
  4. Starta en slinga på den andra klienten för att försöka låsa samma fil.
  5. Starta om OneFS-noden som den första klienten är ansluten till.
  6. Om problemet uppstår beviljas den andra klienten ett lås innan det första klientlåset upphör.

 

Cause

Det uppstod ett fel i vår logik för att flytta NFSv4-anslutningar till andra noder som gjorde att låsen släpptes vid nodomstart.

 

Resolution

Fixa:
Uppgradera eller korrigera till någon av följande versioner av OneFS.

  • 9.1.0.19+
  • 9.2.1.12+
  • 9.4.0.3+
  • 9.5.0.0+

Workaround:
Det finns inga lösningar på problemet.

 

Affected Products

PowerScale OneFS
Article Properties
Article Number: 000215804
Article Type: Solution
Last Modified: 26 Sep 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.