PowerScale. OneFS теряет блокировки NFSv4 при перезагрузке узла

Summary: Клиенты NFSv4 могут потерять блокировки или не могут правильно освободить блокировки после перезагрузки узла.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Эта проблема присутствует во всех версиях OneFS, прежде чем исправить разработку.
Это может повлиять на любое приложение, которое использует NFSv4 и операции блокировки.

Эта проблема чаще всего наблюдалась с приложениями «Очередь сообщений», такими как ActiveMQ или OpenMQ, поскольку они широко используют механизмы блокировки NFSv4.

для приложений MQ; часто он проявляется как дополнительный сервер MQ, который перенимет систему в качестве основного, когда это не так.
Это приводит к сбоям или несоответствиям данных, для устранения которых требуется ручное вмешательство на стороне приложения.

При обнаружении пакетов клиент успешно блокирует файл, пока второй клиент пытается получить к нем доступ.
Когда узел, клиент блокировки подключен к перезагрузке, второму клиенту предоставляется блокировка.
Первый клиент получает сообщение об ошибке, когда его блокировка заканчивается, так как блокировка больше не установлена.

Проблему можно воспроизвести следующим образом:

  1. На первом клиенте смонтируйте экспорт с помощью NFSv4.0.
  2. На втором клиенте смонтируйте тот же экспорт с помощью NFSv4.0.
  3. На первом клиенте заблокируйте файл на 5 минут.
  4. На втором клиенте запустите цикл, который пытается заблокировать тот же файл.
  5. Перезагрузите узел OneFS, к котором подключен первый клиент.
  6. Если проблема возникает, второму клиенту предоставляется блокировка до окончания первого блокировки клиента.

 

Cause

В нашей логике перемещения подключений NFSv4 к другим узлам произошла ошибка, из-за которой блокировки были выпущены при перезагрузке узла.

 

Resolution

Исправить:
Обновите или выполните исправление до одной из следующих версий OneFS.

  • 9.1.0.19+
  • 9.2.1.12+
  • 9.4.0.3+
  • 9.5.0.0+

Решение:
Временных решений для этой проблемы нет.

 

Affected Products

PowerScale OneFS
Article Properties
Article Number: 000215804
Article Type: Solution
Last Modified: 26 Sep 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.