XPS 13 9320 Touchpad is Stuck After Resuming from Sleep Mode

Summary: Learn about what to do if the touchpad is stuck after resuming from sleep on an XPS 13 9320.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The touchpad has no haptic feedback or the left button locks after resuming from sleep mode.

Affected Platforms:

  • XPS 13 9320

Cause

The touchpad runtime calibration failing to detect changes in internal or ambient conditions causes this issue.

Resolution

Updating the touchpad firmware to version 2023.12.13.946, A05 or later on the computer resolves the issue. To download and install the firmware, reference How to Download and Install Dell Drivers and Firmware.

Affected Products

XPS 13 Plus 9320
Article Properties
Article Number: 000220433
Article Type: Solution
Last Modified: 10 Apr 2025
Version:  5
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