Dell Unity: Nieuw toegevoegde gebruikers hebben geen toegang tot delen in een bestandssysteem met meerdere protocollen (op te lossen door gebruiker)

Summary: Nieuw toegevoegde gebruikers hebben geen toegang tot delen in een bestandssysteem met meerdere protocollen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nieuwe gebruikers kunnen geen toegang krijgen tot de share in een bestandssysteem met meerdere protocollen.
Gebruikers worden vermeld onder de tag "unresolved" in de lijst "secmap".

Opdracht:

Type        UID/GID     Origin     Date of creation           Name                       SID
Unresolved xxxxxx  secmap     Mon Jan 22 12:46:52 2024   xxxxx                xxxxxxxxxx


 

Cause

Automatische toewijzing voor niet-toegewezen Windows-accounts is niet ingeschakeld.

In een context met meerdere protocollen moet een Windows-gebruiker worden gekoppeld aan een UNIX-gebruiker. Een UNIX-gebruiker hoeft echter alleen aan een Windows-gebruiker te worden toegewezen als het toegangsbeleid Windows is. Deze overeenkomst is nodig zodat de beveiliging van het bestandssysteem kan worden afgedwongen, zelfs als deze niet eigen is aan het protocol.

De volgende componenten zijn betrokken bij het in kaart brengen van gebruikers:
  • UNIX Directory Services, lokale bestanden of beide
  •  Windows resolvers
  •  Secure mapping (secmap) - een cache die alle toewijzingen bevat tussen SID's en UID of GID's die door een NAS-server worden gebruikt.
  •  ntxmap

De functie van secmap is om alle SID-naar-UID en primaire GID- en UID-naar-SID-toewijzingen op te slaan om coherentie te garanderen op alle bestandssystemen van de NAS-server.

Tijdens de SID naar UID, primaire GID-toewijzing, wordt de UDS (NIS-server, LDAP-server of lokale bestanden) doorzocht met behulp van de UNIX-naam.
  1. Als de UNIX-gebruikersnaam wordt gevonden in de UDS, worden de UID- en GID-toewijzing opgelost.
  2. Als de UNIX-naam niet wordt gevonden, maar de functie automatische toewijzing voor niet-toegewezen Windows-accounts is ingeschakeld, wordt de UID automatisch toegewezen.
  3. Als de UNIX-gebruikersnaam niet wordt gevonden in de UDS, maar er wel een standaard UNIX-account is, wordt de UID- en GID-toewijzing omgezet naar die van het standaard UNIX-account.
  4. Als de SID niet kan worden opgelost, wordt de toegang geweigerd.

 
Raadpleeg de volgende gids voor meer informatie:
https://dl.dell.com/content/manual51476971-dell-emc-unity-family-configuring-multiprotocol-file-sharing.pdf?language=en-us

Resolution

Stap 1: - Haal de secmap-details op met behulp van de onderstaande opdracht.

svc_cifssupport {<NAS_server_name> | ALL} -secmap -list

 


Stap 2: - Zoek de gebruikers in de lijst met onderstaande opdracht:             

 svc_cifssupport {<NAS_server_name> | ALL} -secmap -list | grep "<username>"


De gebruiker kan worden gevonden met de tag "unresolved" in de lijst, zoals wordt weergegeven in het onderstaande voorbeeld:

Type        UID/GID     Origin     Date of creation           Name                       SID
Unresolved xxxxxx  secmap     Mon Jan 22 12:46:52 2024   xxxxx                xxxxxxxxxx


Stap 3: Ga in de gebruikersinterface naar het tabblad Meerdere>protocollen voor delen van de bijbehorende NAS-server > en schakel automatische toewijzing in voor niet-toegewezen Windows-accounts en pas dit toe zoals hieronder weergegeven:

Schermafbeelding van de GUI die laat zien hoe u automatische toewijzing inschakelt voor niet-toegewezen Windows-accounts
Stap 4: Controleer na 10-15 minuten opnieuw of de gebruiker in de lijst "secmap" staat met dezelfde opdracht als in stap 2. 

De gebruikers worden vermeld onder de tag "user" en krijgen toegang tot de shares.

Voorbeeldresultaat: 

Type        UID/GID     Origin     Date of creation           Name                       SID
User        xxxxxx  secmap     Mon Jan 22 13:46:52 2024   xxxxx                xxxxxxxxxx

 

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000223045
Article Type: Solution
Last Modified: 20 May 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.