Dell Unity: Новододані користувачі не можуть отримати доступ до спільного ресурсу в багатопротокольній файловій системі (виправлено користувачем)

Summary: Нещодавно додані користувачі не можуть отримати доступ до спільного ресурсу в багатопротокольній файловій системі.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Нові користувачі не можуть отримати доступ до спільного ресурсу в багатопротокольній файловій системі.
Користувачі перелічені під тегом "unresolved" у списку "secmap".

Команда:

Type        UID/GID     Origin     Date of creation           Name                       SID
Unresolved xxxxxx  secmap     Mon Jan 22 12:46:52 2024   xxxxx                xxxxxxxxxx


 

Cause

Автоматичне зіставлення для незіставлених облікових записів Windows не ввімкнено.

У багатопротокольному контексті користувача Windows має бути зіставлено з користувачем UNIX. Однак, користувача UNIX слід зіставляти з користувачем Windows, лише якщо політика доступу є Windows. Це зіставлення необхідне для забезпечення безпеки файлової системи, навіть якщо вона не є рідною для протоколу.

У зіставленні користувачів беруть участь такі компоненти:
  • Служби каталогів UNIX, локальні файли або і те, і інше
  •  Розв'язувачі Windows
  •  Безпечне прив'язування (secmap) — кеш, який містить усі прив'язки між SID та UID або GID, що використовуються сервером NAS.
  •  ntxmap

Функція secmap полягає у зберіганні всіх відображень SID-to-UID та первинних GID та UID-to-SID для забезпечення узгодженості між усіма файловими системами сервера NAS.

Під час прив'язки SID до UID, первинного прив'язки GID, виконується пошук у UDS (сервері NIS, сервері LDAP або локальних файлах) за назвою UNIX.
  1. Якщо ім'я користувача UNIX знайдено в UDS, буде вирішено прив'язку UID і GID.
  2. Якщо ім'я UNIX не знайдено, але ввімкнено функцію автоматичного зіставлення для незіставлених облікових записів Windows, UID призначається автоматично.
  3. Якщо ім'я користувача UNIX не знайдено в UDS, але є типовий обліковий запис UNIX, прив'язку UID і GID буде вирішено до відповідності типового облікового запису UNIX.
  4. Якщо SID не можна розв'язати, доступ буде заборонено.

 
Зверніться до наступного посібника для отримання додаткової інформації:
https://dl.dell.com/content/manual51476971-dell-emc-unity-family-configuring-multiprotocol-file-sharing.pdf?language=en-us

Resolution

Крок 1:- Отримайте деталі secmap за допомогою наведеної нижче команди.

svc_cifssupport {<NAS_server_name> | ALL} -secmap -list

 


第 2 步:- Перевірте наявність користувачів у списку за допомогою наведеної нижче команди:             

 svc_cifssupport {<NAS_server_name> | ALL} -secmap -list | grep "<username>"


Користувача можна знайти з тегом "unresolved" у списку, як показано в наведеному нижче прикладі:

Type        UID/GID     Origin     Date of creation           Name                       SID
Unresolved xxxxxx  secmap     Mon Jan 22 12:46:52 2024   xxxxx                xxxxxxxxxx


Крок 3: У інтерфейсі користувача перейдіть на вкладку «Багатопротокольні протоколи >спільного доступу» на пов'язаному сервері > NAS і виберіть пункт «Увімкнути автоматичне зіставлення для незіставлених облікових записів Windows» і застосуйте його, як показано нижче:

скріншот графічного інтерфейсу, на якому показано, як увімкнути автоматичне зіставлення для незіставлених облікових записів Windows
Крок 4: Через 10-15 хвилин знову перевірте наявність користувача в списку "secmap" за допомогою тієї ж команди, що і в кроці 2. 

Користувачі потрапляють до списку під тегом "user", і вони отримують доступ до спільних ресурсів.

Приклад вихідних даних: 

Type        UID/GID     Origin     Date of creation           Name                       SID
User        xxxxxx  secmap     Mon Jan 22 13:46:52 2024   xxxxx                xxxxxxxxxx

 

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000223045
Article Type: Solution
Last Modified: 20 May 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.