Latitude, Precision, and XPS Laptops Encounter a Blue Screen Error While Using Camera
Summary: This article provides information about a bluescreen error seen on Latitude, Precision, or XPS laptops while using camera.
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Symptoms
Latitude, Precision, or XPS laptop may show a blue screen error intermittently when using the inbuilt camera module. The camera begins to fail with sticky images, then a 0x9F: "DRIVER_POWER_STATE_FAILURE" error appears. The issue occurs during video meetings such as in Microsoft Teams.
Affected Platforms:
- Latitude 7340
- Latitude 7640
- Latitude 9330
- Latitude 9430
- Latitude 9440 2-in-1
- Precision 5470
- Precision 5480
- Precision 5680
- XPS 13 9315
- XPS 13 Plus 9320
- Dell Pro 13 Premium
Cause
The issue is related to flow control in the camera driver when the camera is powered on shortly and powered off within less than a second. This happens when Microsoft Teams is turning off the camera feed, it re-powers up for less than a second.
Resolution
Updating the latest drivers in the following order resolves the issue. To download and install the driver, reference How to Download and Install Dell Drivers.
- Intel Graphics/Arc Graphics Driver and Intel Graphics Command Center Application
- Intel Integrated Sensor Solution Driver (related about CVF or UPD)
- Intel Serial IO Driver
- Intel 2D Imaging MCU Visual Sensing Controller
- Intel Management Engine Components Installer
Additional Information
Affected Products
Dell Pro 13 Premium PA13250, Latitude 7340, Latitude 9330, Latitude 9430, Latitude 9440 2-in-1, Latitude 7640, Precision 5470, Precision 5480, Precision 5680, XPS 13 9315, XPS 13 Plus 9320Article Properties
Article Number: 000223386
Article Type: Solution
Last Modified: 15 Aug 2025
Version: 13
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