PowerStore: SRM failover test failed with device not found

Summary: SRM failover test failed with device not found

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

From the SRM Recovery Report, the errors are highlighted as below:

Failed to recover datastore 'xxxxxxxx'. VMFS volume residing on recovered devices '"a2d686f3-54ca-4db4-ae21-1ab7f156187a". Recovered device 'a2d686f3-54ca-4db4-ae21-1ab7f156187a' not found after HBA rescan

 

Cause

  • SRM failover test creates a snapshot on the DR PowerStore and maps the snapshot to the DR ESXi hosts with the PowerStore automatically generated Host LUN ID (HLU).
  • The PowerStore automatically generated HLU uses N+1 (where N=highest HLU) logic to enumerate LUN IDs (HLU) up to a max HLU 16383 for ESXi.
  • Esxi max HLU =1024 by default
  • If there are many LUNs protected by SRM and multiple failover tests were performed in the past months, the new mapping HLU could reach to 1024+ which results in the ESXi hosts cannot discover the device mapping on the DR ESXi. This may also affect other applications which automatically map snapshots, see PowerStore: Volumes Mapped Through REST API By an Application Are Not Visible on ESXi

 

Resolution

Increase the Disk.MaxLUN to 16383 on all VMware ESXi hosts in the cluster

 

https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.storage.doc/GUID-22710463-E035-4EB9-8FB1-CA12731D43CA.html This hyperlink is taking you to a website outside of Dell Technologies.

 

 

Affected Products

SRM, PowerStoreOS
Article Properties
Article Number: 000223787
Article Type: Solution
Last Modified: 17 May 2024
Version:  3
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