PowerStore: Test převzetí služeb při selhání SRM se nezdařil se zprávou Device not found
Summary: Test převzetí služeb při selhání SRM se nezdařil se zprávou Device not found
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Ve zprávě o obnovení systému SRM jsou chyby zvýrazněny, jak je uvedeno níže:
Failed to recover datastore 'xxxxxxxx'. VMFS volume residing on recovered devices '"a2d686f3-54ca-4db4-ae21-1ab7f156187a". Recovered device 'a2d686f3-54ca-4db4-ae21-1ab7f156187a' not found after HBA rescan
Cause
- Test převzetí služeb při selhání SRM vytvoří snímek na zařízení DR PowerStore a namapuje snímek na hostitele DR ESXi pomocí automaticky generovaného ID jednotky LUN hostitele (HLU) zařízení PowerStore.
- Automaticky generovaná jednotka HLU zařízení PowerStore používá logiku N+1 (kde N = nejvyšší úroveň HLU) k získání výčtu ID logických jednotek (HLU) až do maximální hodnoty HLU 16383 pro systém ESXi.
- Maximální HLU ESXi = 1024 ve výchozím nastavení.
- Pokud je v systému SRM chráněno mnoho jednotek LUN a v posledních měsících bylo provedeno několik testů převzetí služeb při selhání, může nové mapování HLU dosáhnout hodnoty 1024+, což způsobí, že hostitelé ESXi nebudou moci zjistit mapování zařízení v systému DR ESXi. To může mít vliv i na další aplikace, které automaticky mapují snapshoty. Viz PowerStore: Svazky mapované aplikací prostřednictvím rozhraní REST API nejsou v systému ESXi viditelné
Resolution
Zvyšte počet jednotek Disk.MaxLUN na 16383 na všech hostitelích VMware ESXi v clusteru
https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.storage.doc/GUID-22710463-E035-4EB9-8FB1-CA12731D43CA.html
Affected Products
SRM, PowerStoreOSArticle Properties
Article Number: 000223787
Article Type: Solution
Last Modified: 17 May 2024
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.