VxRail: 암호를 변경한 후 사용자가 vCenter UI에 액세스할 수 없음

Summary: 암호를 변경한 후에는 사용자가 vCenter UI에 액세스할 수 없습니다.

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Symptoms

사용자가 계정 암호를 변경했으며 이제 vCenter 웹 클라이언트에 액세스할 수 없습니다.

다른 관리자 계정으로 로그인을 시도하고 이전 계정 비밀번호를 업데이트했지만 계정이 즉시 잠깁니다.

오류 표시 위치 vmdird.syslog.log:
2024-06-20T14:00:26.712034+08:00 err vmdird  t@139659879360256: Bind Request Failed (127.0.0.1) error 49: Protocol version: 3, Bind DN: "CN=issue account,CN=Users,DC=vsphere,DC=local", Method: SASL
2024-06-20T14:00:29.227039+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-103-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3484)(from )(by )(via Rep)(USN 599050,596449)
2024-06-20T14:00:29.230438+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-112-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3487)(from )(by )(via Rep)(USN 599051,596450)
2024-06-20T14:00:29.232652+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-124-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3491)(from )(by )(via Rep)(USN 599052,596451)
2024-06-20T14:00:29.234951+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-127-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3492)(from )(by )(via Rep)(USN 599053,596452)
2024-06-20T14:00:29.236921+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-34-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3449)(from )(by )(via Rep)(USN 599054,596453)
2024-06-20T14:00:29.239273+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-52-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3455)(from )(by )(via Rep)(USN 599055,596454)
2024-06-20T14:00:29.244296+08:00 info vmdird  t@139660030363392: Modify Entry (cn=vcenter_FQDN02.customer.domain,cn=Servers,cn=Default-First-Site,cn=Sites,cn=Configuration,dc=vsphere,dc=local, EID 3501)(from )(by )(via Int)(USN 599056,0)
2024-06-20T14:00:29.247953+08:00 info vmdird  t@139660030363392: Modify Entry (labeledURI=ldap://vcenter_FQDN01.customer.domain,cn=Replication Agreements,cn=vcenter_FQDN02.customer.domain,cn=Servers,cn=Default-First-Site,cn=Sites,cn=Configuration,dc=vsphere,dc=local, EID 3503)(from )(by )(via Int)(USN 599057,0)
2024-06-20T14:00:29.248020+08:00 info vmdird  t@139660030363392: Replication supplier ldap://vcenter_FQDN01.customer.domain USN range (596446,596454) processed.
2024-06-20T14:00:32.215827+08:00 err vmdird  t@139659879360256: SASLSessionStep: sasl error (-13)(SASL(-13): authentication failure: client evidence does not match what we calculated. Probably a password error)
2024-06-20T14:00:32.216088+08:00 warning vmdird  t@139659879360256: Lockout policy check - account lockout. (cn=issue account,cn=users,dc=vsphere,dc=local)
2024-06-20T14:00:32.216125+08:00 err vmdird  t@139659879360256: VmDirSendLdapResult: Request (Bind), Error (LDAP_INVALID_CREDENTIALS(49)), Message ((49)(SASL step failed.)), (0) socket (127.0.0.1)

Cause

사용자가 administrator@vsphere.local 계좌. 계정에서 제거되었습니다. SystemConfiguration.Administrators 그룹. 만일 administrator@vsphere.local 가 비활성화되고 다른 계정에 동일한 권한이 없으면 계정이 잠깁니다. 계정 업데이트를 해도 암호가 업데이트되지 않습니다.

자세한 내용은 Broadcom 문서 "LDAP 오류 코드 49"/vCenter Server의 vmdird 로그에 있는 오류(49) 오류를 참조하십시오. 이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다.

Resolution

이 문제를 해결하려면 다음을 수행합니다.
  1. 다른 관리 계정을 사용하여 vCenter 웹 클라이언트에 로그인합니다. 활성화 administrator@vsphere.local명령을 입력합니다.
  2. 에서 이미 제거된 경우 SystemConfiguration.Administrators에서 그룹에 다시 추가합니다.
  3. 이전(예전) 메시지로 이동과 administrator@vsphere.local vCenter Web Client에 로그인하려면 문제가 있는 계정을 제거한 후 다시 생성합니다.
SystemConfiguration.Administrators 스크린샷
Article Properties
Article Number: 000226405
Article Type: Solution
Last Modified: 26 Jun 2024
Version:  1
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