NMC: Recover Wizard and Save Sets Tab Return "Could not parse the date time value"

Summary: The NetWorker Management Console (NMC) reports errors regarding the date and time format when a non-US locale is used; for example, French or German.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker Management Console's Recover wizard, or Media Save Sets tab reports:
Could not parse the date time value NON_US_LOCALE_FORMAT
Please enter date time in the following format: "nnn j aaaa h:mm:ss x" i.e jan 3, 2025 12:22:04 PM
For example:

Error appears in NMC stating could not parse date and time value

Cause

This issue was raised to NetWorker engineering under defect NETWORKER-108676.

The NMC runtime environment (for example, NetWorker Runtime Environment) is using a non-US locale.

Resolution

This issue is addressed in NetWorker 19.12.0.2, upgrade to this release or later for a fix.


Workaround:

Change the runtime environment locale to US on the host used to access the NMC.

  1. Open Windows File explorer window and browse to the NetWorker Runtime Environment (NRE) installation path:
C:\Program Files\NRE\java\jre#.#.#_###\bin

NOTE: The Java Runtime Environment (JRE) folder includes different numbers depending on the NetWorker Runtime Environment version installed. If you are using Oracle licensed Java instead of NRE, browse to the location of your JRE bin directory.
  1. Open javacpl.exe from the JRE bin directory.
  2. In the Java Control Panel, go to the Java tab.
  3. Click View to open the JRE Settings.
  4. Select the JRE that you want to configure and click the Runtime Parameters column.
  5. Add the following parameters to set the locale to English (United States):
-Duser.language=en -Duser.country=US
For Example:
Java runtime environment locale settings
  1. Click OK to save the changes.
  2. From the Java Control Panel, Click Apply, then click OK
  3. Close the Java Control Panel.
  4. If the NMC is already open, close the current session and relaunch the NMC. 
Article Properties
Article Number: 000269929
Article Type: Solution
Last Modified: 01 Oct 2025
Version:  3
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