VxRail: Failed to Upgrade the VMware vCenter Server when Exporting Data from Source VM

Summary: During an upgrade of VxRail VCenter, it failed when exporting data from the source vCenter server to the target vCenter server. From the log, it shows that a lot of time was spent on "Exporting VMware Analytics Service data." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

From VxRail lcm-web.log:
2025-08-31T10:27:25.367Z <4304e36e4934ff08fc8120c70e58301b> lcm [WARN] <183> VirtualApplianceUpgradeService.java runUpgrade() (1158): LCM Exception occurred during upgrade for virtual appliance 0 - {}
com.vce.lcm.exception.LCMException: Failed to upgrade the VMware vCenter Server: Failed to export data from source VM VCENTER01.
        at com.vce.lcm.api.LCMServiceImpl.handleUpgradeException(LCMServiceImpl.java:2129)
        at com.vce.lcm.api.LCMServiceImpl.performUpgrade(LCMServiceImpl.java:509)
        at com.emc.mystic.manager.upgrade.service.VirtualApplianceUpgradeService.runUpgrade(VirtualApplianceUpgradeService.java:1134)
        at com.emc.mystic.manager.upgrade.service.PureUpgradeRestServiceImpl.lambda$retryVirtualApplianceUpgrade$0(PureUpgradeRestServiceImpl.java:129)
        at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
        at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
        at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
        at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
        at java.base/java.lang.Thread.run(Thread.java:829)
Caused by: com.vce.lcm.exception.LCMInternalException: Failed to upgrade the VMware vCenter Server: Failed to export data from source VM VCENTER01.
        at com.vce.lcm.core.upgrade.ComponentUpgradeService.performComponentUpgrade(ComponentUpgradeService.java:339)
        at com.vce.lcm.api.LCMServiceImpl.performComponentUpgrade(LCMServiceImpl.java:2439)
        at com.vce.lcm.api.LCMServiceImpl.performCompositeUpgrade(LCMServiceImpl.java:1845)
        at com.vce.lcm.api.LCMServiceImpl.performUpgrade(LCMServiceImpl.java:507)
        ... 7 common frames omitted
From the /var/log/vmware/upgrade/export.json log of the newly developed vCenter server, the upgrade failed when "Exporting VMware Analytics Service data..." with TIME_OUT Error:
{
    "progress": 37,
    "progress_message": {
        "id": "ur.upgrade.script.export.progress.text",
        "translatable": "Exporting %(0)s data...",
        "args": [
            "VMware Analytics Service"
        ],
        "localized": "Exporting VMware Analytics Service data..."
    },
    "status": "error",
    "info": [],
    "warning": [],
    "question": null,
    "error": {
        "detail": [
            {
                "id": "ur.upgrade.execution.timedout.text",
                "translatable": "Upgrade phase timed out. The time planned for the upgrade phase was %(0)s minutes. The upgrade phase has already been running for %(1)s minutes.",
                "args": [
                    60,
                    60
                ],
                "localized": "Upgrade phase timed out. The time planned for the upgrade phase was 60 minutes. The upgrade phase has already been running for 60 minutes."
            }
        ],
        "componentKey": "upgrade_framework",
        "problemId": null,
        "resolution": {
            "id": "ur.upgrade.execution.timedout.resolution",
            "translatable": "To extend the default timeout, set environment variable %(0)s for export upgrade phase, %(1)s for import upgrade phase, and  %(2)s for import historical data phase. The timeout is in minutes.",
            "args": [
                "UPGRADE_EXPORT_TIMEOUT",
                "UPGRADE_IMPORT_TIMEOUT",
                "UPGRADE_POST_IMPORT_TIMEOUT"
            ],
            "localized": "To extend the default timeout, set environment variable UPGRADE_EXPORT_TIMEOUT for export upgrade phase, UPGRADE_IMPORT_TIMEOUT for import upgrade phase, and  UPGRADE_POST_IMPORT_TIMEOUT for import historical data phase. The timeout is in minutes."
        }
    },

Cause

This issue occurs because the push telemetry process sends an excessive number of requests with unique IDs, resulting in the creation of many files in the "/var/log/vmware/analytics/prod" directory. Sometimes, this has led to the accumulation of 185,000 to 375,000 files.

Resolution

Refer to KB https://knowledge.broadcom.com/external/article/322053/vcenter-server-upgrade-from-70-to-80-fai.html (External Link)

  1. Connect to the source vCenter server using SSH
  2. Run the following command to check the number of files created on the vCenter server due to push telemetry process: ls /var/log/vmware/analytics/prod | wc -l
  3. Download the cleaning_vddk_script.sh script from the attachments section of this article.
  4. Upload the script to vCenter and assign "run" permissions with this command: chmod +x cleaning_vddk_script.sh
  5. Run the script: ./cleaning_vddk_script.sh
  6. Restart the upgrade from VxRail plugin.

Affected Products

VxRail, VxRail Appliance Series
Article Properties
Article Number: 000372265
Article Type: Solution
Last Modified: 31 Oct 2025
Version:  3
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