NVP-vProxy: 虚拟机备份或恢复操作失败,并显示“Failed to lock Virtual Machine for backup:另一个 EMC vProxy 操作“File-Level-Recover”在 VM vm-####上处于活动状态
Summary: 使用 NetWorker VMware Protection (NVP) vProxy 应用装置执行的虚拟机备份或恢复操作失败,指示“Failed to lock Virtual Machine”
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NetWorker VMware 保护集成配置了 vProxy Appliance。 vProxy 备份失败,表明另一个 vProxy 文件级恢复 (FLR) 操作处于活动状态,并且无法锁定用于备份的虚拟机 (VM)。
YYYY/MM/DD HH:MM:SS ERROR: [@(#) Build number: 43] Failed to lock Virtual Machine for backup: Another EMC vProxy operation 'File-Level-Recover' is active on VM vm-####
具体取决于正在执行的操作,例如:备份、FLR 等。该错误可能略有不同。一致性将为“failed to lock virtual machine”和“another vProxy operation is active on VM”。
Cause
vProxy 备份和 FLR 工作流在操作开始时设置虚拟机属性,以防止在同一个虚拟机上执行多个 vProxy 操作。 备份工作流将在操作结束时删除虚拟机属性,以允许对虚拟机执行其他操作。 以前的 vProxy FLR 工作流在执行过程中遇到问题,并且未删除虚拟机属性。
Resolution
ProxyHC 实用程序可用于清除在备份或恢复失败或中断后可能遗留的任何剩余属性或工件。
有关下载和设置 ProxyHC 的说明,请参阅:
NVP-vProxy :如何在 vProxy
应用装置上使用运行状况检查工具 ProxyHC1.确保 vCenter 中没有正在运行的备份或恢复。
2.在用于失败的备份/恢复
的 vProxy 上设置 ProxyHC 3。运行以下命令:
如果由于其他作业正在运行或不起作用而无法使用此操作。可以完成以下过程以手动清除虚拟机上的注释。
需要通过 vSphere 客户端手动重置(清除)“Dell EMC vProxy FLR 会话”属性。 以下是该过程的一般概述:
图 1:虚拟机“编辑自定义属性...”vSphere 中的选项。
B。在 虚拟机摘要 选项卡中,选择“编辑”注释 部分。
有关下载和设置 ProxyHC 的说明,请参阅:
NVP-vProxy :如何在 vProxy
应用装置上使用运行状况检查工具 ProxyHC1.确保 vCenter 中没有正在运行的备份或恢复。
2.在用于失败的备份/恢复
的 vProxy 上设置 ProxyHC 3。运行以下命令:
ProxyHC disk tasks cleanup
如果由于其他作业正在运行或不起作用而无法使用此操作。可以完成以下过程以手动清除虚拟机上的注释。
需要通过 vSphere 客户端手动重置(清除)“Dell EMC vProxy FLR 会话”属性。 以下是该过程的一般概述:
- 打开 vSphere Web Client。
- 在 VMware 清单中找到受影响的虚拟机。
- 执行以下选项之一以访问注释:
a.右键单击虚拟机,选择 标签和自定义属性 ,然后选择 编辑自定义属性 :
图 1:虚拟机“编辑自定义属性...”vSphere 中的选项。
B。在 虚拟机摘要 选项卡中,选择“编辑”注释 部分。
图 2: vSphere Web Client 虚拟机自定义属性。
- 选择 Dell EMC vProxy FLR Session 属性,然后单击 X 将其删除。
图 3:删除虚拟机属性所需的步骤。
提醒:(可选)您可以删除所有“Dell EMC”属性。在执行下一个 vProxy 备份、恢复或清理操作时,将重新创建它们。
- 在 编辑注释 窗口中选择“确定”。
Additional Information
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000050701
Article Type: Solution
Last Modified: 18 Sept 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.