DPA : Impossible de s’authentifier avec SharePoint à l’aide des informations d’identification d’administration complètes

Sommaire: Data Protection Advisor signale le message « Impossible d’authentifier l’utilisateur dans le serveur SharePoint » avec les informations d’identification d’administrateur. Les journaux indiquent que NTLM échoue en raison d’informations de domaine manquantes, d’une mauvaise configuration SharePoint. ...

Cet article s’applique à Cet article ne s’applique pas à Cet article n’est lié à aucun produit spécifique. Toutes les versions de produits ne sont pas identifiées dans cet article.

Symptômes



Impossible d’authentifier correctement l’utilisateur disposant d’informations d’identification correctes.
L’erreur signalée dans l’interface graphique DPA lors du test de l’authentification est « Impossible d’authentifier l’utilisateur dans le serveur SharePoint ».

Authentification testée dans Data Protection Advisor (DPA) avec l’exemple suivant : URL :
http://< sharepointserver> :1234/emcdpa

Shared Documents URL :
http://< sharepointserver> :1234/emcdpa/_layouts/15/start.aspx#/Shared %20Documents1/Forms/Allitems.aspx

Le client a suivi la procédure ci-dessous et a vérifié que tout était configuré correctement du côté SharePoint :

  1. Sur la page d’accueil, cliquez sur « Contenu du site »
  2. Cliquez sur + Nouveau sous-site sous Sous-sites.
  3. Saisissez le titre et l’URL (p. ex. emcdpa), configurez les autorisations requises, puis cliquez sur Créer
Comment ajouter des documents partagés :
  1. Sur la page d’accueil (http://< sharepointserver> :1234/emcdpa/), ouvrez « Contenu du site »
  2. Cliquez sur « ajouter une application »
  3. Cliquez sur l’icône Bibliothèque de documents (la première)
  4. Dans « Ajout d’une bibliothèque de documents », entrez « Documents partagés » comme nom
  5. Vérifiez le lien de la page nouvellement créée (il doit se terminer par « /Shared %20Documents/Forms/AllItems.aspx »)
  6. Du côté DPA, tout a également été configuré correctement.
Vérifiez également les éléments suivants - effectué.  
-Telnet du serveur d’applications vers le serveur SharePoint a réussi sur le port 1234-À
partir de l’hôte d’application DPA utilisant le navigateur Web IE (et non via l’interface graphique DPA), peut accéder à l’URL des documents partagés avec succès avec les mêmes informations d’identification utilisateur. 

Erreur détectée dans le fichier log du serveur :

2016-04-25 09:06:02,482 DEBUG [com.emc.dpa.command.serversettings.ValidateSharePointSettingsCommandBean] (Thread-16152 (HornetQ-client-global-threads-279296719)) Échec de la validation des détails Sharepoint à l’aide de l’authentification de base. Essayons maintenant l’authentification NTLM.

2016-04-25 09:06:02,482 DEBUG [com.emc.dpa.command.serversettings.ValidateSharePointSettingsCommandBean] (Thread-16152 (HornetQ-client-global-threads-279296719)) Validation des paramètres Sharepoint à l’aide de l’authentification NTLM

2016-04-25 09:06:02,482 DEBUG [com.emc.dpa.command.serversettings.ValidateSharePointSettingsCommandBean] (Thread-16152 (HornetQ-client-global-threads-279296719)) Hostname is : <sharepointserver>

2016-04-25 09:06:02,482 ERROR [com.emc.dpa.command.serversettings.ValidateSharePointSettingsCommandBean] (Thread-16152 (HornetQ-client-global-threads-279296719)) Sharepoint with NTLM Authentication should have Domain Name :

2016-04-25 09:06:02,482 ERROR [com.emc.dpa.command.serversettings.ValidateSharePointSettingsCommandBean] (Thread-16152 (HornetQ-client-global-threads-279296719)) Got null HTTPResponse. Pour l’authentification NTLM, assurez-vous que les informations de domaine sont également présentes dans le champ Nom d’utilisateur.

Cause

Le serveur SharePoint n’a pas été configuré correctement, ce qui a entraîné le problème d’autorisations.

Résolution

Une fois les experts SharePoint engagés, ils ont trouvé le problème dans le journal SharePoint et ont pu résoudre le problème d’autorisations.

Produits touchés

Data Protection Advisor
Propriétés de l’article
Numéro d’article: 000054858
Type d’article: Solution
Dernière modification: 10 déc. 2025
Version:  5
Obtenez des réponses à vos questions auprès d’autre utilisateurs de Dell
Services de soutien
Vérifiez si votre appareil est couvert par les services de soutien.