ViPR SRM 3.7SP2: VNX collector QDF files back up and Failover-filter cannot recover

Sommaire: Failover mode does not revert. Stuck continuously processing QDF files while adding new data files at the same time.

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Symptômes

Polling for VNX SolutionPack for performance was set to 5 mins. Whenever the VNX Collector goes into Failover mode for any reason QDF files build up in the tmp-backend directory, as designed. However, when connectivity is re-established the collector is not able to "catch up" and process the accumulated files. This leads to the collector never being able to push all the queued up older files in a timely manner causing missing data and gaps.

Files were confirmed to process every 15-20 minutes, with new data being collected every 5 minutes, which causes the issue. When this reaches the maximum limit we see data being dropped:
SEVERE   [2016-12-20 21:23:20 GMT]   FailOverFilter$DumpQueueToDiskTask::run(): Storage space has been exceeded. Dropping 10000 raw values.

Cause

This is a bandwidth issue on the customer network.

This issue was reproduced by stopping the Load-Balancer Collector on the SRM Collector server managing the remote VNX's.

Résolution

There are several options to resolve this issue:
  1. Change the polling cycle to 15 minutes for performance rather than the more intense 5 minute polling cycle.
  2. Upgrade the ViPR SRM to version 4.0.x which has compression of data between the Collector and the Primary Backend available for configuration.
  3. Increase the network bandwidth.

Produits

SRM
Propriétés de l’article
Numéro d’article: 000058976
Type d’article: Solution
Dernière modification: 07 nov. 2025
Version:  4
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