ViPR SRM: Błąd widoczny podczas uruchamiania programu mysql-database-check.sh
Sommaire: mysql-database-check-sh pokazuje, że operacja nie powiodła się
Cet article s’applique à
Cet article ne s’applique pas à
Cet article n’est lié à aucun produit spécifique.
Toutes les versions de produits ne sont pas identifiées dans cet article.
Symptômes
Błąd widoczny po uruchomieniu mysql-database-check.sh
Błąd zaobserwowany:
Błąd zaobserwowany:
Error : Table apg.recovery_group doesn't exist Status : Operation failed
Cause
Tabela apg.recovery_group jest używana podczas sprawdzania bazy danych w celu odzyskania, nie jest to tabela konieczna i nie została utworzona podczas wykonywania zadania w tej chwili.
Résolution
Uruchom ponownie polecenie mysql-database-check-sh. Błąd zostanie usunięty, ponieważ tabela zostanie utworzona ponownie poprawnie podczas wykonywania zadania
Renseignements supplémentaires
Jak uruchomić sprawdzanie bazy danych:
Zaloguj się do każdego hosta zaplecza i uruchom następujące polecenie:
Alternatywnie możemy przeprowadzić kontrole, wykonując poniższe czynności:
Zaloguj się do głównego zaplecza:
Wprowadź bazę danych: [apg]
Wprowadź hasło: watch4net
Na drugorzędnych backendach zaloguj się jako root i wykonaj na każdej z baz danych pojedynczo, takich jak apg1, apg2, apg3 i apg4:
Wprowadź bazę danych: [APG1]
Wprowadź hasło: watch4net
Zaloguj się do każdego hosta zaplecza i uruchom następujące polecenie:
printf "apg\n--password=watch4net --all-databases\n" | /opt/APG/bin/mysql-database-check.sh
Alternatywnie możemy przeprowadzić kontrole, wykonując poniższe czynności:
Zaloguj się do głównego zaplecza:
srm:/opt/APG/bin # ./mysql-database-check.shWprowadź nazwę użytkownika: [apg]
Wprowadź bazę danych: [apg]
Wprowadź hasło: watch4net
Na drugorzędnych backendach zaloguj się jako root i wykonaj na każdej z baz danych pojedynczo, takich jak apg1, apg2, apg3 i apg4:
srm:/opt/APG/bin # ./mysql-database-check.shWprowadź nazwę użytkownika: [apg]
Wprowadź bazę danych: [APG1]
Wprowadź hasło: watch4net
Produits touchés
SRMPropriétés de l’article
Numéro d’article: 000167710
Type d’article: Solution
Dernière modification: 20 juin 2024
Version: 5
Obtenez des réponses à vos questions auprès d’autre utilisateurs de Dell
Services de soutien
Vérifiez si votre appareil est couvert par les services de soutien.