CloudLink: Får felmeddelandet "Det går inte att hämta det begärda certifikatet"

Sommaire: När du försöker upprätta förtroende för CloudLink i vCenter visas felmeddelandet "Det går inte att hämta det begärda certifikatet".

Cet article s’applique à Cet article ne s’applique pas à Cet article n’est lié à aucun produit spécifique. Toutes les versions de produits ne sont pas identifiées dans cet article.

Symptômes

I vCenter går det inte att upprätta förtroende till CloudLink under den första konfigurationen av nyckelprovidern.

Få ett felmeddelande enligt nedan:
Cannot retrieve the requested certificate
 
Skärmbild av felmeddelande

Cause

En orsak till det här felet är att vCenter inte kan kommunicera med CloudLink via port 5696.

En annan möjlig orsak är att användaren kör versioner av CloudLink och vCenter som inte är kompatibla.

Résolution

  1. SSH-ansluta till vCenter-enheten
  2. Kör följande kommandon:
ping cloudlinkip
curl -v telnet://cloudlinkip:5696
curl -v --local-port 10000 telnet://cloudlinkip:5696
curl -v --local-port 20000 telnet://cloudlinkip:5696
curl -v --local-port 30000 telnet://cloudlinkip:5696
curl -v --local-port 40000 telnet://cloudlinkip:5696
curl -v --local-port 50000 telnet://cloudlinkip:5696
curl -v --local-port 60000 telnet://cloudlinkip:5696
  1. Om ping - eller curl-kommandona misslyckas kan det tyda på ett brandväggs- eller nätverksproblem. Användaren bör kontrollera med nätverksteamet och se till att de nödvändiga portarna är öppna och bekräfta att de virtuella CloudLink-datorerna är anslutna till rätt nätverk eller VLAN.
  2. Om curl-kommandona lyckas tas ett meddelande emot med texten "Ansluten till x.x.x.x" enligt den här skärmbilden:
Skärmbild av lyckad anslutning
  1. Om ping- och curl- eller telnet-kommandona lyckas kontrollerar du att CloudLink- och vCenter-versionerna är kompatibla. Du kan få felmeddelandet Det går inte att hämta det begärda certifikatet om vCenter 8.x med CloudLink 7.1.7 eller tidigare används. I VMware Compatibility GuideDen här hyperlänken tar dig till en webbplats utanför Dell Technologies. finns information om vilka vCenter- och CloudLink-versioner som stöds
CloudLink 7.0 stöds med vCenter 6.x och 7.x.
CloudLink 7.1.x stöds med vCenter 6.x och 7.x.
CloudLink 8.x stöds med vCenter 7.x och 8.x.

CloudLink 8.x är den version som officiellt stöds med vCenter 8.x, men CloudLink 7.1.8 och 7.1.9 verkar fungera med vCenter 8.x.
  1. Uppgradering av CloudLink till 7.1.8, 7.1.9 eller 8.x bör lösa problemet och kunna skapa förtroende.
 
Friskrivning: Om användaren kör PowerFlex kanske hen inte kan uppgradera till vissa versioner av CloudLink. De måste behålla den CloudLink-version som anges i RCM-konfigurationen.

Produits touchés

CloudLink
Propriétés de l’article
Numéro d’article: 000223969
Type d’article: Solution
Dernière modification: 13 nov. 2025
Version:  4
Obtenez des réponses à vos questions auprès d’autre utilisateurs de Dell
Services de soutien
Vérifiez si votre appareil est couvert par les services de soutien.