Dell製コンピューターのレガシー モードでの「No Bootable Device Found」エラーの解決方法
概要: ノートパソコンおよびデスクトップの「No bootable devices were found」エラーを解決。UEFIモードに切り替えてWindows 10またはLinuxを再インストールすることで、起動デバイスが使用できない、検出されない、または見つからない場合の問題を修正する方法について説明します。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
以下のガイドラインに従って、次のエラー メッセージを解決します。
ブート シーケンスがレガシー モードに設定されている場合、またはオペレーティング システムがレガシー モードでインストールされている場合に、「 No boot device found」エラー が表示されます。
No boot device foundエラー
オペレーティング システムのインストール後に、起動デバイスが見つかりません。
このエラーは、デバイスのBIOSブート シーケンスがレガシー モードに設定されている場合に発生します。

オペレーティング システムがレガシー モードでインストールされている場合、PCを再起動するとエラー メッセージが表示されます。この障害は、BIOS設定をUnified Extensible Firmware Interface (UEFI)に戻しても回復できません。オペレーティング システムを再インストールする必要があります。
注:
- これらの特定のDell PCでは、UEFI起動モードのWindows 10以降およびLinuxオペレーティング システムのみがサポートされています。
- オペレーティング システムを再インストールする前に、BIOSでUEFIモードが有効になっていることを確認してください。
- 光学ドライブを使用したオペレーティング システムのインストールは、ブート メニューに光学ドライブ オプションがないため、レガシー モードではサポートされていません。
- 上記のDell製コンピューターには、第7世代Coffee Lakeプロセッサー(およびそれ以降)が搭載されています。コンピューターは、UEFIでのみ起動するように設計されています。ブート環境。
- その結果、これらのコンピューターでレガシー起動モードが選択されている場合、オペレーティング システムは起動に失敗します。
原因
BIOSで設定されている起動モードが間違っている。
解決方法
ブート シーケンスを変更する前にUEFIを使用してオペレーティング システムがインストールされている場合は、ブート シーケンスをUEFIに戻すことでコンピューターを回復できます。
オペレーティング システムがレガシー モードでインストールされている場合、ブート シーケンスをUEFIモードに戻してもコンピューターを回復できません
オペレーティング システムの再インストールを実行する必要があります。
Windows 10以降を再インストールするには、次の手順に従います。
- 電源オフの状態からPCの電源を入れ、Dellのロゴ画面で F2 を押してBIOSセットアップ メニューを起動します。
- [Boot sequence]を選択し、オプションを[Legacy]から[UEFI]に変更して、画面の右下隅にある[Apply]をクリックします。
![BIOS設定で[Boot List Option]を[Legacy]から[UEFI]に変更する](https://supportkb.dell.com/img/ka0Do000000lzCQIAY/ka0Do000000lzCQIAY_ja_1.jpeg)
- [Advanced Boot Options]を選択し、[Enable Legacy Option ROMs]を無効にしてから、画面の右下隅にある[Apply]をクリックします。
![BIOS設定の[Enable Legacy Option ROMs]](https://supportkb.dell.com/img/ka0Do000000lzCQIAY/ka0Do000000lzCQIAY_ja_2.jpeg)
- [Secure Boot -> Secure Boot Enable]を選択し、オプションを[Disabled]から[Enabled]に変更します。
- 次に、画面の右下隅にある[ Apply ]をクリックします。
![BIOSで[Secure Boot Enable]設定を有効にする](https://supportkb.dell.com/img/ka0Do000000lzCQIAY/ka0Do000000lzCQIAY_ja_3.jpeg)
- 画面の右下隅にある [終了 ]をクリックして、コンピューターが再起動するのを待ちます。
- Windows 10オペレーティング システムを再インストールします。
Linuxオペレーティング システムをインストールするには、次の手順に従います。
- 上記の手順1~3に従って、Windows 10をインストールする手順を実行します(Linuxをインストールする場合もこれらの手順は同じです)。
- BIOSで [Secure Boot] > [Secure Boot Enable ]オプションが [Disabled] になっていることを確認します。
![BIOSの[Secure Boot Enable]を無効にする](https://supportkb.dell.com/img/ka0Do000000lzCQIAY/ka0Do000000lzCQIAY_ja_4.jpeg)
- SATA操作->SATA操作を選択し、AHCIモードに変更します。

- 右下隅にある [終了 ]をクリックして、コンピューターが再起動するのを待ちます。
- Linuxオペレーティング システムを再インストールします。
詳細については、Dellナレッジベース記事を参照してください。
その他の情報
推奨記事
ここでは、このトピックに関連した役立つ可能性のある推奨記事をいくつか紹介します。
対象製品
Alienware, Dell Pro All-in-One, Dell Pro Max Micro, Dell Pro Max Slim, Dell Pro Max Tower, Dell Pro Micro, Dell Pro Slim, Dell Pro Tower, Dell Tower, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Dell Pro, Dell Pro Max
, Dell Pro Plus, Dell Pro Premium, Inspiron, Latitude, Dell Pro Rugged, Vostro, XPS, Fixed Workstations, Mobile Workstations, Dell Pro Max Micro XE FCM2250
...
文書のプロパティ
文書番号: 000128655
文書の種類: Solution
最終更新: 30 7月 2025
バージョン: 18
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。