Dell EMC Unity: Chyba „Failed to get technical advisory with configured proxy“ (oprava uživatelem)

概要: Chyby při získávání technických doporučení

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Při pokusu o získání technických doporučení v prostředí Unisphere se vygeneruje následující chybová zpráva:

There was an error when retrieving catalog from Dell EMC through configured proxy (Error Code:0x6400bda)'

EMCSystemLogFile.log shows the following:
2021-01-28T17:09:09.974Z" "xxx_spb@APM00123456789" "Neo_CEM" "17037" "local/admin" "WARN" "14:380012" :: "Failed to get technical advisory with configured proxy http://proxy.FQDN.com:8080." :: Category=User Component=EmcSupportServices TimeZone=UTC


The curl command to check connectivity to the Proxy server is failing:

# curl -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v

Hostname was NOT found in DNS cache
Could not resolve host: colu.emc.com
Closing connection 0
curl: (6) Could not resolve host: colu.emc.com


Adding the proxy server to the curl command succeeds.

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive


<--zkráceno-->
(úplný výstup naleznete v poznámkách)

原因

V takovém případě zákazník nepovolí přímý přístup k serveru DNS a k výstupu využije pouze proxy server.  Příčinou tohoto problému je, že připojení mezi webem colu.emc.com a proxy serverem bylo uzavřeno před dokončením přenosu dat mezi prostředím Unity a proxy serverem.  Zdá se, že je to způsobeno tím, jak proces curl zpracovává připojení.

解決方法

Oprava
Oprava tohoto problému bude zahrnuta v budoucí verzi operačního prostředí Dell EMC Unity OE.  Sledujte tento článek znalostní databáze, protože v něm budou přibývat aktualizace.

Zástupné řešení
K vyhledávání technických doporučení nepoužívejte proxy server nebo pro prostředí Unisphere nastavte dočasné obcházení, dokud nebude vydán kód, který tento problém opraví.

その他の情報

Po přidání části „proxy server URL“ proběhne příkaz curl úspěšně:

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, Certificate (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
* subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
* start date: 2020-08-25 03:21:00 GMT
* expire date: 2022-08-25 03:21:00 GMT
* subjectAltName: colu.emc.com matched
* issuer: C=US; O=Entrust, Inc.; OU=See www.entrust.net/legal-terms; OU=(c) 2012 Entrust, Inc. - for authorized use only; CN=Entrust Certification Authority - L1K
* SSL certificate verify ok.

対象製品

Dell EMC Unity Family
文書のプロパティ
文書番号: 000182700
文書の種類: Solution
最終更新: 19 8月 2021
バージョン:  3
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。