CloudLink: CloudLink agent is not upgraded automatically after CloudLink cluster has been upgraded to a new version.

概要: CloudLink agent is not upgraded automatically after CloudLink cluster has been upgraded to a new version.

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現象

  • CloudLink agent is not upgraded automatically after CloudLink cluster has been upgraded to a new version.
  • All agent policies are set to Automatic upgrade.
  • Following the CloudLink server upgrade to version 7.1.5, no agent was upgraded and all agents report version as 7.1.133.
  • Tried to set a policy to manual upgrade in order to upgrade the agent manually, but the upgrade option is unavailable for all agents even if the policy is manual.
  • Uninstalled the agent on one of the protected VMs and installed the agent again. It was showing the original agent version of 7.1.133

原因

Working as designed.
Occasionally the same agent is used for versions of two releases.
Occasionally there is a difference in Linux agent version but no change for Windows agent.

解決方法

This is working as designed. Check the customer's agent Operating System type, CloudLink source code, and destination code version to check if the agent version must be upgraded.

In this instance, the agent version does not need to be upgraded if the current version matches the mapping matrix as below:
CloudLink Version      Windows Agent        Linux Agent
CloudLink 7.1.1 7.1 (build 9) 7.1 (build 32)
CloudLink 7.1.2 7.1 (build 111) 7.1 (build 111)
CloudLink 7.1.3 7.1 (build 133) 7.1 (build 136)
CloudLink 7.1.4 7.1 (build 133) 7.1 (build 136)
CloudLink 7.1.5 7.1 (build 133) 7.1 (build 140)
CloudLink 7.1.6 7.1 (build 133) 7.1 (build 140)

製品

CloudLink
文書のプロパティ
文書番号: 000212227
文書の種類: Solution
最終更新: 17 5月 2026
バージョン:  4
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