Data Domain Management Center genstarter hver time efter opgradering

概要: Systemet genstarter spontant ca. hver time efter opgradering af PowerProtect DD Management Center (DDMC). Dette sker på grund af et problem med filen til kørsel af Docker Process Identifier (PID). ...

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

  • Efter opgraderingen genstarter DDMC næsten hver time.
  • Der er ingen indlysende meddelelser i kern.info eller messages.engineering, der angiver, hvorfor systemet blev genstartet
  • Logmeddelelser, der ligner nedenstående, findes i /ddr/var/log/debug/docker/psm.log:
01/31 10:16:27.951 ERROR: run_cmd: stderr: None
01/31 10:16:27.951 ERROR: run_cmd: stdout: b'Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?\n'

原因

Dette er en sjælden situation, hvor docker blev lukket uværdigt ned, og PID-filen (var/run/docker.pid) ikke ryddes korrekt. Docker kan ikke starte, når der er en eksisterende PID-fil. Dette er forventeligt.

解決方法

På grund af at systemet genstarter ugraciøst, kører mekanismen, der fjerner den forældede PID-fil, aldrig. Hvis du efter DDMC genstarter en manuel genstart af DDMC, bør dette stoppe genstartsløjfen.

Hvis ikke, skal du kontakte Dell Support, hvorefter en tekniker manuelt kan fjerne docker PID-filen fra DDMC i bash:
# rm /var/run/docker.pid
文書のプロパティ
文書番号: 000221727
文書の種類: Solution
最終更新: 13 2月 2024
バージョン:  1
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。