Data Domain Management Center Reboots Hourly After Upgrade
概要: The system reboots spontaneously approximately every hour after upgrading PowerProtect DD Management Center (DDMC). This happens due to an issue with the docker process identifier (PID) run file. ...
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
- After the upgrade, the DDMC reboots on an almost hourly cadence.
- There are no obvious messages in kern.info or messages.engineering to indicate why the system was rebooted
- Log messages similar to the below are present in /ddr/var/log/debug/docker/psm.log:
01/31 10:16:27.951 ERROR: run_cmd: stderr: None 01/31 10:16:27.951 ERROR: run_cmd: stdout: b'Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?\n'
原因
This is a rare situation where docker was ungracefully shut down and the PID file (var/run/docker.pid) is not correctly cleared. Docker cannot start when there is an existing PID file. This is expected behavior.
解決方法
Due to the system rebooting ungracefully, the mechanism that removes the stale PID file never runs. After the DDMC reboots, if you initiate a manual reboot of the DDMC, this should stop the reboot loop.
If not, contact Dell Support and an engineer can manually remove the docker PID file from the DDMC in bash:
If not, contact Dell Support and an engineer can manually remove the docker PID file from the DDMC in bash:
# rm /var/run/docker.pid
文書のプロパティ
文書番号: 000221727
文書の種類: Solution
最終更新: 13 2月 2024
バージョン: 1
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。