Data Domain Management Center wordt elk uur opnieuw opgestart na upgrade
概要: Het systeem wordt ongeveer elk uur spontaan opnieuw opgestart na de upgrade van PowerProtect DD Management Center (DDMC). Dit gebeurt vanwege een probleem met het run-bestand van de docker process identifier (PID). ...
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
- Na de upgrade wordt de DDMC bijna elk uur opnieuw opgestart.
- Er zijn geen duidelijke berichten in kern.info of messages.engineering om aan te geven waarom het systeem opnieuw is opgestart
- Logboekberichten zoals hieronder zijn aanwezig in /ddr/var/log/debug/docker/psm.log:
01/31 10:16:27.951 ERROR: run_cmd: stderr: None 01/31 10:16:27.951 ERROR: run_cmd: stdout: b'Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?\n'
原因
Dit is een zeldzame situatie waarin docker ongebruikelijk is afgesloten en het PID-bestand (var/run/docker.pid) niet correct is gewist. Docker kan niet starten als er een bestaand PID-bestand is. Dit is normaal gedrag.
解決方法
Omdat het systeem onregelmatig opnieuw opstart, wordt het mechanisme dat het verouderde PID-bestand verwijdert nooit uitgevoerd. Als u na het opnieuw opstarten van de DDMC een handmatige herstart van de DDMC initieert, zou dit de herstart-lus moeten stoppen.
Als dit niet het geval is, neemt u contact op met Dell Support zodat een technicus het docker PID-bestand handmatig uit de DDMC kan verwijderen in bash:
Als dit niet het geval is, neemt u contact op met Dell Support zodat een technicus het docker PID-bestand handmatig uit de DDMC kan verwijderen in bash:
# rm /var/run/docker.pid
文書のプロパティ
文書番号: 000221727
文書の種類: Solution
最終更新: 13 2月 2024
バージョン: 1
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。