AppSync: Appsync-backup.bat in Debug Mode My Stop Responding with Message: Failed to Create Keycloak Directory
Summary: Appsync-backup.bat in debug mode may stop responding with message: Failed to create keycloak directory: C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
Acest articol se aplică pentru
Acest articol nu se aplică pentru
Acest articol nu este legat de un produs specific.
Acest articol nu acoperă toate versiunile de produs existente.
Symptoms
Any function that performs an AppSync database backup may stop responding if any of these folders exist on the drive the product uses for installation.
Running appsync-backup.bat from the <install dir>\backup-assistant folder in debug mode like:
Stops responding with the following error assuming "C" was the install drive:
\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox \EMC\AppSync\jboss\datastore\data\AppSync_Keycloak \EMC\AppSync\jboss\datastore\data\configFiles \EMC\AppSync\jboss\datastore\data\AppSync_Ese \EMC\AppSync\jboss\datastore\data\AppSync_LIC
appsync-backup -d
Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
Cause
Appsync-backup.bat that is run on a database that did not have an array that is defined, which is known to stop responding for AppSync 4.4 and later, leaves the following folders in place (assuming the install drive is C:):
This causes subsequent runs of the appsync-backup.bat utility, even when run inherently during upgrades, to stop responding. However, running manually in debug mode does show the error:
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak C:\EMC\AppSync\jboss\datastore\data\configFiles C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC
Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
Resolution
Delete the following folders:
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak C:\EMC\AppSync\jboss\datastore\data\configFiles C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC
Produse
AppSyncProprietăți articol
Article Number: 000200777
Article Type: Solution
Ultima modificare: 14 mai 2026
Version: 7
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.