NVP vProxy: Não é possível fazer log-in usando credenciais root, acesso root perdido

摘要: O acesso à conta root por meio do dispositivo vProxy é perdido.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

No VMware vSphere Web Client, não é possível fazer log-in no appliance vProxy usando a conta root. Erros de credenciais de acesso negado ou inválidos são retornados.
 
Nota: O acesso root é bloqueado por SSH por padrão. A menos que as configurações do arquivo de configuração do SSHD no vProxy estejam definidas para habilitar root via SSH, o acesso root retornará "Access Denied" via SSH. A conta root pode ser acessada por meio da conexão do console da VM do vSphere Web Client.

Você não consegue fazer log-in usando a conta de administrador do vProxy a partir do SSH ou do vSphere we client. Os erros access Denied ou Invalid Credential são exibidos.

原因

A conta root e os usuários administradores estão bloqueados ou as credenciais do usuário são perdidas ou desconhecidas.

解决方案

Se o acesso for perdido para a conta de usuário root e admin, o vProxy deverá ser reimplementado.

Se a conta root estiver acessível:
Se a conta root estiver acessível por meio da conexão do console do vSphere Web Client, conecte-se ao vProxy via SSH e faça log-in com credenciais de administrador. Alterne para a conta de usuário root usando o comando abaixo e especifique a senha dos usuários root.
sudo su -
Você só poderá alterar (atualizar) a senha root se já tiver acesso à conta root.
sudo passwd root
Se a senha do usuário administrador for perdida, mas souber a senha root, conecte-se ao vProxy a partir do web client do vSphere e faça log-in como root. A senha de administrador pode ser alterada com o comando:
passwd admin
 
Nota: Se você alterar a senha do usuário administrador, deverá atualizar a senha do vProxy no NetWorker. Caso contrário, ele continuará a tentar usar a senha antiga e bloqueará a conta.
 
 Captura de tela da página de senha do vProxy
Figura 1: Captura de tela da página de senha do vProxy

Se a conta de administrador estiver bloqueada, faça log-in com a conta root do vSphere Web Client e redefina a conta de administrador com pam_tally2 para redefini-la:
pam_tally2 --user admin --reset

受影响的产品

NetWorker

产品

NetWorker Family, NetWorker Series
文章属性
文章编号: 000215827
文章类型: Solution
上次修改时间: 06 11月 2025
版本:  7
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。