Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell FluidFS V3 NAS Solutions For PowerVault NX3500, NX3600, And NX3610Administrator's Guide

PDF

Troubleshooting An NDMP Internal Error

Description

Backup or restore fails with an internal error.

Cause

NDMP internal errors are indicators of a file system not being accessible or a NAS volume not being available.

Workaround

If the backup application cannot connect to a NAS appliance:

  1. Log in to the NAS Manager or open a remote terminal to the appliance.
  2. On the NAS Manager, go to Data Protection > NDMP > NDMP Configuration page. In NAS CLI, go to Data Protection NDMP Configuration menu.
  3. Verify that NDMP is enabled. If NDMP is enabled, go to step 5.
  4. On the NAS Manager, the Enabled check box must be checked.
  5. In the NAS CLI, type view and ensure that State is set to  Enabled.
  6. If NDMP is not enabled, enable it.
  7. Verify that backup application IP address is configured in NDMP.
  8. On the NAS Manager, the DMA server list must include the IP address of the backup application.
  9. In the NAS CLI, type view and ensure that the DMA Servers list includes the IP address of the DMA application trying to access the NAS appliance.

If the backup appliance can connect to a NAS appliance but cannot log in, use backup_user as the user name for the NDMP client, while setting up the NDMP backup/restore in your backup application. The default password for NDMP client is Stor@ge!

To change the password:

  1. Log in to the NAS Manager or open remote terminal to the appliance.
  2. In the NAS Manager, go to Data Protection > NDMP > NDMP Configuration page. In NAS CLI, go to Data Protection > NDMP > Configuration menu.
  3. In the NAS Manager, click Change Password. In the NAS CLI, run the command:
    data-protection ndmp configuration set-Password <new_password>

If the backup application can log into the NAS appliance, but if no volumes are available for backup, verify that the NAS appliance has NAS volumes created on it.


Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\