Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.1

PDF

Example: Active-active PIM in a square VLT topology

The following topology uses active/active PIM in a square VLT environment:

Active-active PIM in a square VLT topology
  • CR1, CR2, AG1, AG2, AG3, and AG4 are multicast routers.
  • CR1 and CR2 are the BSR and RP nodes.
  • TR1 and TR2 are IGMP-enabled L2 nodes.
  • OSPFv2 is the unicast routing protocol.

CR1 switch

  1. Configure RSTP.

    CR1(config)# spanning-tree disable
  2. Configure the VLT domain.

    CR1(config)# interface ethernet 1/1/27:2
    CR1(conf-if-eth1/1/27:2)# no switchport
    
    CR1(config)#vlt-domain 128
    CR1(conf-vlt-128)# backup destination 10.222.208.160
    CR1(conf-vlt-128)# discovery-interface ethernet1/1/27:2
    CR1(conf-vlt-128)# peer-routing
    CR1(conf-vlt-128)# primary-priority 1
    CR1(conf-vlt-128)# vlt-mac 9a:00:00:aa:aa:aa
  3. Configure a port channel interface towards AG1 and AG2.
    CR1(config)# interface port-channel 11
    
    CR1(config)# interface ethernet 1/1/1:1
    CR1(conf-if-eth1/1/1:1)# channel-group 11 mode active
    
    CR1(config)# interface ethernet 1/1/9:1
    CR1(conf-if-eth1/1/9:1)# channel-group 11 mode active
    
    CR1(config)# interface port-channel 11
    CR1(conf-if-po-11)# vlt-port-channel 11
  4. Configure a port channel interface towards AG3.
    CR1(config)# interface port-channel 21
    
    CR1(config)# interface ethernet 1/1/25:1
    CR1(conf-if-eth1/1/25:1)# channel-group 21 mode active
  5. Configure a port channel interface towards AG4.
    CR1(config)# interface port-channel 31
    
    CR1(config)# interface ethernet 1/1/17:1
    CR1(conf-if-eth1/1/17:1)# channel-group 31 mode active
  6. Configure a Loopback interface and enable PIM-sparse mode.
    CR1(config)# interface loopback 1
    CR1(conf-if-lo-1)# ip address 10.1.100.5/32
    CR1(conf-if-lo-1)# ip pim sparse-mode
  7. Enable multicast routing on the default VRF.
    CR1(config)# ip multicast-routing
  8. Enable BSR.
    CR1(config)# ip pim bsr-candidate loopback1 hash-mask-len 31 priority 199
  9. Enable the RP candidate.
    CR1(config)# ip pim rp-candidate loopback1 priority 100 acl mcast_acl
  10. Configure an access-list for RP mapping.
    CR1(config)# ip access-list mcast_acl
    CR1(config-ipv4-acl)# permit ip any 225.0.0.0/8
  11. Configure OSPF for unicast routing.
    CR1(config)# router ospf 1
    CR1(config-router-ospf-1)# log-adjacency-changes
    CR1(config-router-ospf-1)# redistribute connected
    CR1(config-router-ospf-1)# router-id 10.1.100.5
  12. Configure the IP address, OSPF process, and PIM-SM on the VLANs.
    • VLAN 100 towards CR2
      CR1(config)# interface vlan 100
      CR1(conf-if-vl-100)# ip address 10.1.1.5/24
      CR1(conf-if-vl-100)# ip ospf 1 area 0.0.0.0
      CR1(conf-if-vl-100)# ip pim sparse-mode
      CR1(conf-if-vl-100)# ip pim dr-priority 1
    • VLAN 1001 towards AG1 and AG2
      CR1(config)# interface vlan 1001
      CR1(conf-if-vl-1001)# ip address 10.1.2.5/24
      CR1(conf-if-vl-1001)# ip ospf 1 area 0.0.0.0
      CR1(conf-if-vl-1001)# ip pim sparse-mode
      CR1(conf-if-vl-1001)# ip igmp snooping mrouter interface port-channel11
    • VLAN 1101 towards AG3
      CR1(config)# interface vlan 1101
      CR1(conf-if-vl-1101)# ip address 10.1.3.5/24
      CR1(conf-if-vl-1101)# ip ospf 1 area 0.0.0.0
      CR1(conf-if-vl-1101)# ip pim sparse-mode
      CR1(conf-if-vl-1101)# ip ospf cost 65535
      CR1(conf-if-vl-1101)#ip igmp snooping mrouter interface port-channel21
    • VLAN 1201 towards AG4
      CR1(config)# interface vlan 1201
      CR1(conf-if-vl-1201)# ip address 10.1.4.5/24
      CR1(conf-if-vl-1201)# ip ospf 1 area 0.0.0.0
      CR1(conf-if-vl-1201)# ip pim sparse-mode
      CR1(conf-if-vl-1201)# ip ospf cost 65535
      CR1(conf-if-vl-1201)#ip igmp snooping mrouter interface port-channel31
  13. Configure the interfaces as VLAN trunk ports and specify the allowed VLANs.
    CR1(config)# interface port-channel 11
    CR1(conf-if-po-11)# switchport mode trunk
    CR1(conf-if-po-11)# switchport trunk allowed vlan 1001
    CR1(config)# interface port-channel 21
    CR1(conf-if-po-21)# switchport mode trunk
    CR1(conf-if-po-21)# switchport trunk allowed vlan 1101
    CR1(config)# interface port-channel 31
    CR1(conf-if-po-31)# switchport mode trunk
    CR1(conf-if-po-31)# switchport trunk allowed vlan 1201
    CR1(config)# interface ethernet 1/1/28:1
    CR1(conf-if-eth1/1/28:1)# switchport mode trunk
    CR1(conf-if-eth1/1/28:1)# switchport trunk allowed vlan 100
    CR1(config)# interface ethernet 1/1/28:3
    CR1(conf-if-eth1/1/28:3)# switchport mode trunk
    CR1(conf-if-eth1/1/28:3)# switchport trunk allowed vlan 100

CR2 switch

  1. Configure RSTP.
    CR2(config)# spanning-tree disable
  2. Configure the VLT domain.
    CR2(config)# interface ethernet 1/1/27:2
    CR2(conf-if-eth1/1/27:2)# no switchport
    
    CR2(config)#vlt-domain 128
    CR2(conf-vlt-128)# backup destination 10.222.208.238
    CR2(conf-vlt-128)# discovery-interface ethernet1/1/27:2
    CR2(conf-vlt-128)# peer-routing
    CR2(conf-vlt-128)# primary-priority 65535
    CR2(conf-vlt-128)# vlt-mac 9a:00:00:aa:aa:aa
  3. Configure a port channel interface towards AG1 and AG2.
    CR2(config)# interface port-channel 11
    
    CR2(config)# interface ethernet 1/1/1:1
    CR2(conf-if-eth1/1/1:1)# channel-group 11 mode active
    
    CR2(config)# interface ethernet 1/1/9:1
    CR2(conf-if-eth1/1/9:1)# channel-group 11 mode active
    
    CR2(config)# interface port-channel 11
    CR2(conf-if-po-11)# vlt-port-channel 11
    
  4. Configure a port channel interface towards AG3.
    CR2(config)# interface port-channel 22
    
    CR2(config)# interface ethernet 1/1/25:1
    CR2(conf-if-eth1/1/25:1)# channel-group 22 mode active
  5. Configure a port channel interface towards AG4.
    CR2(config)# interface port-channel 32
    
    CR2(config)# interface ethernet 1/1/17:1
    CR2(conf-if-eth1/1/17:1)# channel-group 32 mode active
  6. Configure a Loopback interface and enable PIM-SM.
    CR2(config)# interface loopback 1
    CR2(conf-if-lo-1)# ip address 10.1.100.6/32
    CR2(conf-if-lo-1)# ip pim sparse-mode
  7. Enable multicast routing on the default VRF.
    CR2(config)# ip multicast-routing
  8. Enable BSR. This router becomes the elected BSR.
    CR2(config)# ip pim bsr-candidate loopback1 hash-mask-len 31 priority 99
    
  9. Enable the RP candidate.
    CR2(config)# ip pim rp-candidate loopback1 priority 100 acl mcast_acl
  10. Configure an access list for RP mapping.
    CR2(config)# ip access-list mcast_acl
    CR2(config-ipv4-acl)# permit ip any 225.0.0.0/8
  11. Configure OSPF for unicast routing.
    CR2(config)# router ospf 1
    CR2(config-router-ospf-1)# log-adjacency-changes
    CR2(config-router-ospf-1)# redistribute connected
    CR2(config-router-ospf-1)# router-id 10.1.100.6
  12. Configure the IP address, OSPF process, and PIM sparse mode on the VLANs.
    • VLAN 100 towards CR1
      CR2(config)# interface vlan 100
      CR2(conf-if-vl-100)# ip address 10.1.1.6/24
      CR2(conf-if-vl-100)# ip ospf 1 area 0.0.0.0
      CR2(conf-if-vl-100)# ip pim sparse-mode
      CR2(conf-if-vl-100)# ip pim dr-priority 4294967295
    • VLAN 1001 towards AG1 and AG2
      CR2(config)# interface vlan 1001
      CR2(conf-if-vl-1001)# ip address 10.1.2.6/24
      CR2(conf-if-vl-1001)# ip ospf 1 area 0.0.0.0
      CR2(conf-if-vl-1001)# ip pim sparse-mode
      CR2(conf-if-vl-1001)# ip igmp snooping mrouter interface port-channel11
      
    • VLAN 1151 towards AG3
      CR2(config)# interface vlan 1151
      CR2(conf-if-vl-1151)# ip address 10.110.1.5/24
      CR2(conf-if-vl-1151)# ip ospf 1 area 0.0.0.0
      CR2(conf-if-vl-1151)# ip pim sparse-mode
      CR2(conf-if-vl-1151)# ip ospf cost 65535
      CR2(conf-if-vl-1151)#ip igmp snooping mrouter interface port-channel22
      
    • VLAN 1251 towards AG4
      CR2(config)# interface vlan 1251
      CR2(conf-if-vl-1251)# ip address 10.192.168.5/24
      CR2(conf-if-vl-1251)# ip ospf 1 area 0.0.0.0
      CR2(conf-if-vl-1251)# ip pim sparse-mode
      CR2(conf-if-vl-1251)# ip ospf cost 65535
      CR2(conf-if-vl-1251)#ip igmp snooping mrouter interface port-channel32
  13. Configure the interfaces as VLAN trunk ports and specify the allowed VLANs.
    CR2(config)# interface port-channel 11
    CR2(conf-if-po-11)# switchport mode trunk
    CR2(conf-if-po-11)# switchport trunk allowed vlan 1001
    CR2(config)# interface port-channel 22
    CR2(conf-if-po-22)# switchport mode trunk
    CR2(conf-if-po-22)# switchport trunk allowed vlan 1151
    CR2(config)# interface port-channel 32
    CR2(conf-if-po-32)# switchport mode trunk
    CR2(conf-if-po-32)# switchport trunk allowed vlan 1251
    CR2(config)# interface ethernet 1/1/28:2
    CR2(conf-if-eth1/1/28:2)# switchport mode trunk
    CR2(conf-if-eth1/1/28:2)# switchport trunk allowed vlan 100
    CR2(config)# interface ethernet 1/1/28:4
    CR2(conf-if-eth1/1/28:4)# switchport mode trunk
    CR2(conf-if-eth1/1/28:4)# switchport trunk allowed vlan 100

AG1 switch

  1. Configure RSTP.
    AG1(config)# spanning-tree mode rstp
    AG1(config)# spanning-tree rstp priority 0
  2. Configure the VLT domain.
    AG1(config)# interface ethernet 1/1/25:1
    AG1(conf-if-eth1/1/25:1)# no switchport
    
    AG1(config)#vlt-domain 1
    AG1(conf-vlt-1)# backup destination 10.222.208.211
    AG1(conf-vlt-1)# discovery-interface ethernet1/1/25:1
    AG1(conf-vlt-1)# peer-routing
    AG1(conf-vlt-1)# primary-priority 1
    AG1(conf-vlt-1)# vlt-mac de:11:de:11:de:11
  3. Configure a port channel interface towards CR1 and CR2.
    AG1(config)# interface port-channel 11
    
    AG1(config)# interface ethernet 1/1/1:1
    AG1(conf-if-eth1/1/1:1)# channel-group 11 mode active
    
    AG1(config)# interface ethernet 1/1/3:1
    AG1(conf-if-eth1/1/3:1)# channel-group 11 mode active
    
    AG1(config)# interface port-channel 11
    AG1(conf-if-po-11)# vlt-port-channel 11
    AG1(conf-if-po-11)# spanning-tree disable
  4. Configure a port channel interface towards AG3 and AG4.
    AG1(config)# interface port-channel 1
    AG1(conf-if-po-1)# vlt-port-channel 1
    
    AG1(config)# interface ethernet 1/1/24:1
    AG1(conf-if-eth1/1/24:1)# channel-group 1 mode active
    
    AG1(config)# interface ethernet 1/1/26:1
    AG1(conf-if-eth1/1/26:1)# channel-group 1 mode active
  5. Configure a port channel interface towards TR1.
    AG1(config)# interface port-channel 41
    AG1(conf-if-po-41)# vlt-port-channel 41
    
    AG1(config)# interface ethernet 1/1/17:1
    AG1(conf-if-eth1/1/17:1)# channel-group 41 mode active
  6. Configure a Loopback interface and enable PIM-SM.
    AG1(config)# interface loopback 1
    AG1(conf-if-lo-1)# ip address 10.1.100.1/32
    AG1(conf-if-lo-1)# ip pim sparse-mode
    
  7. Enable multicast routing on the default VRF.
    AG1(config)# ip multicast-routing
  8. Configure OSPF for unicast routing.
    AG1(config)# router ospf 1
    AG1(config-router-ospf-1)# log-adjacency-changes
    AG1(config-router-ospf-1)# redistribute connected
    AG1(config-router-ospf-1)# router-id 10.1.100.1
  9. Configure the IP address, OSPF process, and PIM-SM on the VLANs.
    • VLAN 1001 towards CR1 and CR2
      AG1(config)# interface vlan 1001
      AG1(conf-if-vl-1001)# ip address 10.1.2.1/24
      AG1(conf-if-vl-1001)# ip ospf 1 area 0.0.0.0
      AG1(conf-if-vl-1001)# ip pim sparse-mode
      AG1(conf-if-vl-1001)# ip igmp snooping mrouter interface port-channel11
    • VLAN 1301 towards AG3 and AG4
      AG1(config)# interface vlan 1301
      AG1(conf-if-vl-1301)# ip address 10.112.1.1/24
      AG1(conf-if-vl-1301)# ip ospf 1 area 0.0.0.0
      AG1(conf-if-vl-1301)# ip pim sparse-mode
      AG1(conf-if-vl-1301)# ip igmp snooping mrouter interface port-channel1
    • VLAN 2001 towards TR1
      AG1(config)# interface vlan 2001
      AG1(conf-if-vl-2001)# ip address 192.168.1.1/24
      AG1(conf-if-vl-2001)# ip pim sparse-mode
      AG1(conf-if-vl-2001)# ip pim dr-priority 4294967295
      AG1(conf-if-vl-2001)# ip igmp snooping mrouter interface port-channel1
  10. Configure the interfaces as VLAN trunk ports and specify the allowed VLANs.
    AG1(config)# interface port-channel 11
    AG1(conf-if-po-11)# switchport mode trunk
    AG1(conf-if-po-11)# switchport trunk allowed vlan 1001
    AG1(config)# interface port-channel 1
    AG1(conf-if-po-1)# switchport mode trunk
    AG1(conf-if-po-1)# switchport trunk allowed vlan 1301,2001
    AG1(config)# interface port-channel 41
    AG1(conf-if-po-41)# switchport mode trunk
    AG1(conf-if-po-41)# switchport trunk allowed vlan 2001
    AG1(config)# interface ethernet 1/1/6:2
    AG1(conf-if-eth1/1/6:2)# switchport mode trunk
    AG1(conf-if-eth1/1/6:2)# switchport trunk allowed vlan 2001
    AG1(conf-if-eth1/1/6:2)# spanning-tree port type edge

AG2 switch

  1. Configure RSTP.
    AG2(config)# spanning-tree mode rstp
    AG2(config)# spanning-tree rstp priority 4096
  2. Configure the VLT domain.
    AG2(config)# interface ethernet 1/1/25:1
    AG2(conf-if-eth1/1/25:1)# no switchport
    
    AG2(config)#vlt-domain 1
    AG2(conf-vlt-1)# backup destination 10.16.208.218
    AG2(conf-vlt-1)# discovery-interface ethernet1/1/25:1
    AG2(conf-vlt-1)# peer-routing
    AG2(conf-vlt-1)# primary-priority 65535
    AG2(conf-vlt-1)# vlt-mac de:11:de:11:de:11
  3. Configure a port channel interface towards CR1 and CR2.
    AG2(config)# interface port-channel 11
    
    AG2(config)# interface ethernet 1/1/1:1
    AG2(conf-if-eth1/1/1:1)# channel-group 11 mode active
    
    AG2(config)# interface ethernet 1/1/3:1
    AG2(conf-if-eth1/1/3:1)# channel-group 11 mode active
    
    AG2(config)# interface port-channel 11
    AG2(conf-if-po-11)# vlt-port-channel 11
    AG2(conf-if-po-11)# spanning-tree disable
  4. Configure a port channel interface towards AG3 and AG4.
    AG2(config)# interface port-channel 1
    AG2(conf-if-po-1)# vlt-port-channel 1
    
    AG2(config)# interface ethernet 1/1/24:1
    AG2(conf-if-eth1/1/24:1)# channel-group 1 mode active
    
    AG2(config)# interface ethernet 1/1/26:1
    AG2(conf-if-eth1/1/26:1)# channel-group 1 mode active
  5. Configure a port channel interface towards TR1.
    AG2(config)# interface port-channel 41
    AG2(conf-if-po-41)# vlt-port-channel 41
    
    AG2(config)# interface ethernet 1/1/17:1
    AG2(conf-if-eth1/1/17:1)# channel-group 41 mode active
  6. Configure Loopback interface and enable PIM-SM.
    AG2(config)# interface loopback 1
    AG2(conf-if-lo-1)# ip address 10.1.100.2/32
    AG2(conf-if-lo-1)# ip pim sparse-mode
  7. Enable multicast routing on the default VRF.
    AG2(config)# ip multicast-routing
  8. Configure OSPF for unicast routing.
    AG2(config)# router ospf 1
    AG2(config-router-ospf-1)# log-adjacency-changes
    AG2(config-router-ospf-1)# redistribute connected
    AG2(config-router-ospf-1)# router-id 10.1.100.2
  9. Configure the IP address, OSPF process, and PIM-SM on the VLANs.
    • VLAN 1001 towards CR1 and CR2
      AG2(config)# interface vlan 1001
      AG2(conf-if-vl-1001)# ip address 10.1.2.2/24
      AG2(conf-if-vl-1001)# ip ospf 1 area 0.0.0.0
      AG2(conf-if-vl-1001)# ip pim sparse-mode
      AG2(conf-if-vl-1001)# ip igmp snooping mrouter interface port-channel11
    • VLAN 1301 towards AG3 and AG4
      AG2(config)# interface vlan 1301
      AG2(conf-if-vl-1301)# ip address 10.112.1.2/24
      AG2(conf-if-vl-1301)# ip ospf 1 area 0.0.0.0
      AG2(conf-if-vl-1301)# ip pim sparse-mode
      AG2(conf-if-vl-1301)# ip igmp snooping mrouter interface port-channel1
    • VLAN 2001 towards TR1
      AG2(config)# interface vlan 2001
      AG2(conf-if-vl-2001)# ip address 192.168.1.2/24
      AG2(conf-if-vl-2001)# ip pim sparse-mode
      AG2(conf-if-vl-2001)# ip pim dr-priority 4294967290
      AG2(conf-if-vl-2001)# ip igmp snooping mrouter interface port-channel1
  10. Configure the interfaces as VLAN trunk ports and specify the allowed VLANs.
    AG2(config)# interface port-channel 11
    AG2(conf-if-po-11)# switchport mode trunk
    AG2(conf-if-po-11)# switchport trunk allowed vlan 1001
    
    AG2(config)# interface port-channel 1
    AG2(conf-if-po-1)# switchport mode trunk
    AG2(conf-if-po-1)# switchport trunk allowed vlan 1301,2001
    AG2(config)# interface port-channel 41
    AG2(conf-if-po-41)# switchport mode trunk
    AG2(conf-if-po-41)# switchport trunk allowed vlan 2001
    AG2(config)# interface ethernet 1/1/6:2
    AG2(conf-if-eth1/1/6:2)# switchport mode trunk
    AG2(conf-if-eth1/1/6:2)# switchport trunk allowed vlan 2001
    AG2(conf-if-eth1/1/6:2)# spanning-tree port type edge

AG3 switch

  1. Configure RSTP.
    AG3(config)# spanning-tree mode rstp
    AG3(config)# spanning-tree rstp priority 8192
  2. Configure the VLT domain.
    AG3(config)# interface ethernet 1/1/25:1
    AG3(conf-if-eth1/1/25:1)# no switchport
    
    AG3(config)#vlt-domain 1
    AG3(conf-vlt-255)# backup destination 10.222.208.39
    AG3(conf-vlt-255)# discovery-interface ethernet1/1/25:1
    AG3(conf-vlt-255)# peer-routing
    AG3(conf-vlt-255)# primary-priority 1
    AG3(conf-vlt-255)# vlt-mac f0:ce:10:f0:ce:10
  3. Configure a port channel interface towards CR1.
    AG3(config)# interface port-channel 21
    
    AG3(config)# interface ethernet 1/1/1:1
    AG3(conf-if-eth1/1/1:1)# channel-group 21 mode active
  4. Configure a port channel interface towards CR2.
    AG3(config)# interface port-channel 22
    
    AG3(config)# interface ethernet 1/1/4:1
    AG3(conf-if-eth1/1/4:1)# channel-group 22 mode active
  5. Configure a port channel interface towards AG3 and AG4.
    AG3(config)# interface port-channel 1
    AG3(conf-if-po-1)# vlt-port-channel 1
    
    AG3(config)# interface ethernet 1/1/24:1
    AG3(conf-if-eth1/1/24:1)# channel-group 1 mode active
    
    AG3(config)# interface ethernet 1/1/26:1
    AG3(conf-if-eth1/1/26:1)# channel-group 1 mode active
  6. Configure a port channel interface towards TR2.
    AG3(config)# interface port-channel 51
    AG3(conf-if-po-51)# vlt-port-channel 51
    
    AG3(config)# interface ethernet 1/1/17:1
    AG3(conf-if-eth1/1/17:1)# channel-group 51 mode active
  7. Enable multicast routing on the default VRF.
    AG3(config)# ip multicast-routing
  8. Configure OSPF for unicast routing.
    AG3(config)# router ospf 1
    AG3(config-router-ospf-1)# log-adjacency-changes
    AG3(config-router-ospf-1)# redistribute connected
    AG3(config-router-ospf-1)# router-id 10.1.100.3
  9. Configure the IP address, OSPF process, and PIM-SM on the VLANs.
    • VLAN 1101 towards CR1
      AG3(config)# interface vlan 1101
      AG3(conf-if-vl-1101)# ip address 10.1.3.3/24
      AG3(conf-if-vl-1101)# ip ospf 1 area 0.0.0.0
      AG3(conf-if-vl-1101)# ip pim sparse-mode
      AG3(conf-if-vl-1101)# ip igmp snooping mrouter interface port-channel21
    • VLAN 1151 towards CR2
      AG3(config)# interface vlan 1151
      AG3(conf-if-vl-1151)# ip address 10.110.1.3/24
      AG3(conf-if-vl-1151)# ip ospf 1 area 0.0.0.0
      AG3(conf-if-vl-1151)# ip pim sparse-mode
      AG3(conf-if-vl-1151)# ip igmp snooping mrouter interface port-channel22
    • VLAN 1301 towards AG1 and AG2
      AG3(config)# interface vlan 1301
      AG3(conf-if-vl-1301)# ip address 10.112.1.3/24
      AG3(conf-if-vl-1301)# ip ospf 1 area 0.0.0.0
      AG3(conf-if-vl-1301)# ip pim sparse-mode
      AG3(conf-if-vl-1301)# ip igmp snooping mrouter interface port-channel1
      
    • VLAN 2001 towards TR2
      AG3(config)# interface vlan 2001
      AG3(conf-if-vl-2001)# ip address 192.168.1.3/24
      AG3(conf-if-vl-2001)# ip pim sparse-mode
      AG3(conf-if-vl-2001)# ip pim dr-priority 100000
      AG3(conf-if-vl-2001)# ip igmp snooping mrouter interface port-channel1
      
  10. Configure the interfaces as VLAN trunk ports and specify the allowed VLANs.
    AG3(config)# interface port-channel 21
    AG3(conf-if-po-21)# switchport mode trunk
    AG3(conf-if-po-21)# switchport trunk allowed vlan 1101
    AG3(conf-if-po-21)# spanning-tree disable
    AG3(config)# interface port-channel 22
    AG3(conf-if-po-22)# switchport mode trunk
    AG3(conf-if-po-22)# switchport trunk allowed vlan 1201
    AG3(conf-if-po-22)# spanning-tree disable
    AG3(config)# interface port-channel 1
    AG3(conf-if-po-1)# switchport mode trunk
    AG3(conf-if-po-1)# switchport trunk allowed vlan 1301,2001
    AG3(config)# interface port-channel 51
    AG3(conf-if-po-51)# switchport mode trunk
    AG3(conf-if-po-51)# switchport trunk allowed vlan 2001
    AG3(config)# interface ethernet 1/1/32:2
    AG3(conf-if-eth1/1/32:2)# switchport mode trunk
    AG3(conf-if-eth1/1/32:2)# switchport trunk allowed vlan 2001
    AG3(conf-if-eth1/1/32:2)# spanning-tree port type edge

AG4 switch

  1. Configure RSTP.
    AG4(config)# spanning-tree mode rstp
    AG4(config)# spanning-tree rstp priority 12288
  2. Configure the VLT domain.
    AG4(config)# interface ethernet 1/1/25:1
    AG4(conf-if-eth1/1/25:1)# no switchport
    
    AG4(config)#vlt-domain 1
    AG4(conf-vlt-255)# backup destination 10.222.208.219
    AG4(conf-vlt-255)# discovery-interface ethernet1/1/25:1
    AG4(conf-vlt-255)# peer-routing
    AG4(conf-vlt-255)# primary-priority 65535
    AG4(conf-vlt-255)# vlt-mac f0:ce:10:f0:ce:10
  3. Configure a port channel interface towards CR1.
    AG4(config)# interface port-channel 31
    
    AG4(config)# interface ethernet 1/1/1:1
    AG4(conf-if-eth1/1/1:1)# channel-group 31 mode active
  4. Configure a port channel interface towards CR2.
    AG4(config)# interface port-channel 32
    
    AG4(config)# interface ethernet 1/1/4:1
    AG4(conf-if-eth1/1/4:1)# channel-group 32 mode active
  5. Configure a port channel interface towards AG3 and AG4.
    AG4(config)# interface port-channel 1
    AG4(conf-if-po-1)# vlt-port-channel 1
    
    AG4(config)# interface ethernet 1/1/24:1
    AG4(conf-if-eth1/1/24:1)# channel-group 1 mode active
    
    AG4(config)# interface ethernet 1/1/26:1
    AG4(conf-if-eth1/1/26:1)# channel-group 1 mode active
  6. Configure a port channel interface towards TR2.
    AG4(config)# interface port-channel 51
    AG4(conf-if-po-51)# vlt-port-channel 51
    
    AG4(config)# interface ethernet 1/1/17:1
    AG4(conf-if-eth1/1/17:1)# channel-group 51 mode active
  7. Enable multicast routing on the default VRF.
    AG4(config)# ip multicast-routing
  8. Configure OSPF for unicast routing.
    AG4(config)# router ospf 1
    AG4(config-router-ospf-1)# log-adjacency-changes
    AG4(config-router-ospf-1)# redistribute connected
    AG4(config-router-ospf-1)# router-id 10.1.100.4
  9. Configure the IP address, OSPF process, and PIM-SM on the VLANs.
    • VLAN 1201 towards CR1
      AG4(config)# interface vlan 1201
      AG4(conf-if-vl-1201)# ip address 10.1.4.4/24
      AG4(conf-if-vl-1201)# ip ospf 1 area 0.0.0.0
      AG4(conf-if-vl-1201)# ip pim sparse-mode
      AG4(conf-if-vl-1201)# ip igmp snooping mrouter interface port-channel31
    • VLAN 1251 towards CR2
      AG4(config)# interface vlan 1251
      AG4(conf-if-vl-1251)# ip address 10.192.168.4/24
      AG4(conf-if-vl-1251)# ip ospf 1 area 0.0.0.0
      AG4(conf-if-vl-1251)# ip pim sparse-mode
      AG4(conf-if-vl-1511)# ip igmp snooping mrouter interface port-channel32
    • VLAN 1301 towards AG1 and AG2
      AG4(config)# interface vlan 1301
      AG4(conf-if-vl-1301)# ip address 10.112.1.4/24
      AG4(conf-if-vl-1301)# ip ospf 1 area 0.0.0.0
      AG4(conf-if-vl-1301)# ip pim sparse-mode
      AG4(conf-if-vl-1301)# ip igmp snooping mrouter interface port-channel1
    • VLAN 2001 towards TR2
      AG4(config)# interface vlan 2001
      AG4(conf-if-vl-2001)# ip address 192.168.1.4/24
      AG4(conf-if-vl-2001)# ip pim sparse-mode
      AG4(conf-if-vl-2001)# ip igmp snooping mrouter interface port-channel1
  10. Configure the interfaces as VLAN trunk ports and specify the allowed VLANs.
    AG4(config)# interface port-channel 31
    AG4(conf-if-po-31)# switchport mode trunk
    AG4(conf-if-po-31)# switchport trunk allowed vlan 1201
    AG4(conf-if-po-31)# spanning-tree disable
    AG4(config)# interface port-channel 32
    AG4(conf-if-po-32)# switchport mode trunk
    AG4(conf-if-po-32)# switchport trunk allowed vlan 1251
    AG4(conf-if-po-32)# spanning-tree disable
    AG4(config)# interface port-channel 1
    AG4(conf-if-po-1)# switchport mode trunk
    AG4(conf-if-po-1)# switchport trunk allowed vlan 1301,2001
    AG4(config)# interface port-channel 51
    AG4(conf-if-po-51)# switchport mode trunk
    AG4(conf-if-po-51)# switchport trunk allowed vlan 2001
    AG4(config)# interface ethernet 1/1/32:2
    AG4(conf-if-eth1/1/32:2)# switchport mode trunk
    AG4(conf-if-eth1/1/32:2)# switchport trunk allowed vlan 2001
    AG4(conf-if-eth1/1/32:2)# spanning-tree port type edge

TR1 switch

  1. Configure RSTP.
    TR1(config)# spanning-tree mode rstp
  2. Configure a port channel interface towards AG1.
    TR1(config)# interface port-channel 41
    
    TR1(config)# interface ethernet 1/1/39
    TR1(conf-if-eth1/1/39)# channel-group 41 mode active
  3. Configure a port channel interface towards AG2.
    TR1(config)# interface ethernet 1/1/27:1
    TR1(conf-if-eth1/1/27:1)# channel-group 41 mode active
  4. Configure VLAN 2001 towards AG1 and AG2.
    TR1(config)# interface vlan 2001
  5. Configure the interfaces as VLAN trunk ports and specify the allowed VLANs.
    TR1(config)# interface port-channel 41
    TR1(conf-if-po-41)# switchport mode trunk
    TR1(conf-if-po-41)# switchport trunk allowed vlan 2001
    TR1(config)# interface ethernet 1/1/31
    TR1(conf-if-eth1/1/31)# switchport mode trunk
    TR1(conf-if-eth1/1/31)# switchport trunk allowed vlan 2001
    TR1(conf-if-eth1/1/31)# spanning-tree port type edge
    TR1(config)# interface ethernet 1/1/32
    TR1(conf-if-eth1/1/32)# switchport mode trunk
    TR1(conf-if-eth1/1/32)# switchport trunk allowed vlan 2001
    TR1(conf-if-eth1/1/32)# spanning-tree port type edge

TR2 switch

  1. Configure RSTP.
    TR2(config)# spanning-tree mode rstp
  2. Configure a port channel interface towards AG3.
    TR2(config)# interface port-channel 51
    
    TR2(config)# interface ethernet 1/1/1
    TR2(conf-if-eth1/1/1)# channel-group 51 mode active
  3. Configure a port channel interface towards AG4.
    TR2(config)# interface ethernet 1/1/25:1
    TR2(conf-if-eth1/1/25:1)# channel-group 51 mode active
  4. Configure VLAN 2001 towards AG1 and AG2.
    TR2(config)# interface vlan 2001
  5. Configure the interfaces as VLAN trunk ports and specify the allowed VLANs.
    TR2(config)# interface port-channel 51
    TR2(conf-if-po-51)# switchport mode trunk
    TR2(conf-if-po-51)# switchport trunk allowed vlan 2001
    TR2(config)# interface ethernet 1/1/21
    TR2(conf-if-eth1/1/31)# switchport mode trunk
    TR2(conf-if-eth1/1/31)# switchport trunk allowed vlan 2001
    TR2(conf-if-eth1/1/31)# spanning-tree port type edge
    TR2(config)# interface ethernet 1/1/22
    TR2(conf-if-eth1/1/32)# switchport mode trunk
    TR2(conf-if-eth1/1/32)# switchport trunk allowed vlan 2001
    TR2(conf-if-eth1/1/32)# spanning-tree port type edge

Verify the configuration

You can use the following show commands to verify the configuration.

CR1

The show ip pim interface command displays the PIM-enabled interfaces on the node.

CR1# show ip pim interface 
Address    Interface  Ver/Mode Nbr Count  Query Intvl  DR Prio  DR
--------------------------------------------------------------------------
10.1.1.5  vlan100    v2/S      1          30          1        10.1.1.6           
10.1.3.5  vlan1101   v2/S      1          30          1        10.1.3.5           
10.1.4.5  vlan1201   v2/S      1          30          1        10.1.4.5           
10.1.2.5  vlan1001   v2/S      3          30          1        10.1.2.6

The show ip pim neighbor command displays the PIM neighbor of the node and the interface to reach the neighbor.

CR1# show ip pim neighbor 
Neighbor Address  Interface  Uptime/Expires         Ver           DR Priority / Mode
-------------------------------------------------------------------------------------
10.1.1.6          vlan100    00:24:19/00:01:25        v2           4294967295 / DR S        
10.1.3.3          vlan1101   00:20:28/00:01:18        v2           1          / S           
10.1.4.4          vlan1201   00:18:21/00:01:24        v2           1          / S           
10.1.2.1          vlan1001   00:22:12/00:01:36        v2           1          / S           
10.1.2.2          vlan1001   00:17:38/00:01:36        v2           1          / S           
10.1.2.6          vlan1001   00:24:17/00:01:36        v2           1          / DR S  

The show ip pim summary command displays the PIM summary.

CR1# show ip pim summary 
  
Entries in PIM-TIB/MFC: 96/52  
  
Active Modes:
    PIM-SM  
  
Interface summary:
    4 active PIM interfaces
    0 passive PIM interfaces
    6 active PIM neighbor
  
TIB Summary:
    20/12 (*,G) entries in PIM-TIB/MFC
    40/40 (S,G) entries in PIM-TIB/MFC
    36/0 (S,G,Rpt) entries in PIM-TIB/MFC
  
    2 RP
    3 sources
    0 Register states
  
Message Summary:
    189/770 Joins/Prunes sent/received
    0/56 Candidate-RP advertisements sent/received
    420/112 BSR messages sent/received
  
    267 Null Register messages received
    357/0 Register-stop messages sent/received
  
Data path event summary:
    0 last-hop switchover messages received
    28/28 pim-assert messages sent/received
    0/119 register messages sent/received
  
VLT Multicast summary:
    0(*,G) synced entries in MFC
    20(S,G) synced entries in MFC
    0(S,G,Rpt) synced entries in MFC

The show ip pim tib command displays the PIM tree information base (TIB).

CR1# show ip pim tib 
  
PIM Multicast Routing Table
Flags: S - Sparse, C - Connected, L - Local, P - Pruned,
       R - RP-bit set, F - Register Flag, T - SPT-bit set, J - Join SPT,
       K - Ack-Pending state
Timers: Uptime/Expires
Interface state: Interface, next-Hop, State/Mode
 
(*, 225.1.0.0), uptime 01:42:49, expires 00:00:00, RP 10.1.100.6, flags: SC
  Incoming interface: vlan100, RPF neighbor 10.1.1.6
  Outgoing interface list:
    
  
(172.16.1.201, 225.1.0.0), uptime 01:24:45, expires 00:02:46, flags: CTP
  Incoming interface: vlan100, RPF neighbor 0.0.0.0
  Outgoing interface list:
   

The show ip pim mcache command displays the multicast route entries.

CR1# show ip pim mcache 
PIM Multicast Routing Cache Table
 
(192.168.1.201, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan1
     
(192.168.1.202, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan1
     
(172.16.1.201, 225.1.0.0)
  Incoming interface : vlan1
  Outgoing interface list :
   vlan1001

The show ip pim mcache vlt command displays the multicast route entries synchronized between the VLT peers.

CR1# show ip pim mcache vlt | no-more
PIM Multicast Routing Cache Table
Flags: S - Synced
 
(192.168.1.201, 225.1.0.0),flags: S
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan100 (S)
     
(192.168.1.202, 225.1.0.0),flags: S
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan100 (S)
     
(172.16.1.201, 225.1.0.0)
  Incoming interface : vlan1
  Outgoing interface list :
   vlan1001 (S)
     

The show ip pim bsr-router command displays information about the BSR.

CR1# show ip pim bsr-router 
  
 This system is the Bootstrap Router (v2) 
    BSR address: 10.1.100.5
    BSR Priority: 199, Hash mask length: 31
    Next bootstrap message in 00:00:12
    This system is a candidate BSR
    Candidate BSR address: 10.1.100.5, priority: 199, hash mask length: 31
    Next Cand_RP_advertisement in 00:00:24
    RP: 10.1.100.5(loopback1)

The show ip pim rp command displays information about all multicast group-to-RP mappings.

CR1# show ip pim rp
Group           RP
---------------------------------
225.1.0.0       10.1.100.6
CR1# show ip pim rp mapping 
Group(s) : 225.0.0.0/8
RP : 10.1.100.5, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:00:56 
Group(s) : 225.0.0.0/8
RP : 10.1.100.6, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:01:07 

The show ip igmp snooping groups command displays the IGMP database.

CR1# show ip igmp snooping groups 
Total Number of Groups: 320
CR1# show ip igmp snooping groups vlan 1 225.1.0.0 detail 
Interface      vlan1
Group          225.1.0.0
Source List
 --                  
   Member Port         Mode                Uptime              Expires                       
   port-channel1000    IGMPv2-Compat       01:56:53            00:02:07                      
   ethernet1/1/28:1    IGMPv2-Compat       01:56:53            00:02:03

CR2

The show ip pim interface command displays the PIM-enabled interfaces on the node.

CR2# show ip pim interface 
Address    Interface   Ver/Mode Nbr Count Query Intvl      DR Prio      DR
------------------------------------------------------------------------------------
10.1.1.6     vlan100     v2/S     1         30               4294967295 10.1.1.6           
10.110.1.5   vlan1151    v2/S     1         30               1          10.110.1.5           
10.192.168.5 vlan1251    v2/S     1         30               1          10.192.168.5           
10.1.2.6     vlan1001    v2/S     3         30               1          10.1.2.6  

The show ip pim neighbor command displays the PIM neighbor of the node and the interface to reach the neighbor.

CR2# show ip pim neighbor
Neighbor Address Interface  Uptime/Expires      Ver  DR Priority / Mode
------------------------------------------------------------------------
10.1.1.5         vlan100    00:26:16/00:01:28   v2   1          / S           
10.110.1.3       vlan1151   00:22:17/00:01:29   v2   1          / S           
10.192.168.4     vlan1251   00:20:13/00:01:31   v2   1          / S           
10.1.2.1         vlan1001   00:24:09/00:01:39   v2   1          / S           
10.1.2.2         vlan1001   00:19:35/00:01:39   v2   1          / S           
10.1.2.5         vlan1001   00:26:14/00:01:42   v2   1          / S   

The show ip pim summary command displays the PIM summary.

CR2# show ip pim summary 
   
Entries in PIM-TIB/MFC: 98/59  
  
Active Modes:
    PIM-SM  
  
Interface summary:
    4 active PIM interfaces
    0 passive PIM interfaces
    6 active PIM neighbor
  
TIB Summary:
    20/20 (*,G) entries in PIM-TIB/MFC
    39/39 (S,G) entries in PIM-TIB/MFC
    39/0 (S,G,Rpt) entries in PIM-TIB/MFC
  
    2 RP
    3 sources
    16 Register states
  
Message Summary:
    208/885 Joins/Prunes sent/received
    60/0 Candidate-RP advertisements sent/received
    310/405 BSR messages sent/received
  
    205 Null Register messages received
    268/181 Register-stop messages sent/received
  
Data path event summary:
    11 last-hop switchover messages received
    28/28 pim-assert messages sent/received
    186/79 register messages sent/received
  
VLT Multicast summary:
    0(*,G) synced entries in MFC
    21(S,G) synced entries in MFC
    0(S,G,Rpt) synced entries in MFC

The show ip pim tib command displays the PIM tree information base (TIB).

CR2# show ip pim tib
  
PIM Multicast Routing Table
Flags: S - Sparse, C - Connected, L - Local, P - Pruned,
       R - RP-bit set, F - Register Flag, T - SPT-bit set, J - Join SPT,
       K - Ack-Pending state
Timers: Uptime/Expires
Interface state: Interface, next-Hop, State/Mode
 
(*, 225.1.0.0), uptime 01:43:37, expires 00:00:00, RP 10.1.100.6, flags: SC
  Incoming interface:  Null, RPF neighbor 0.0.0.0
  Outgoing interface list:
    vlan100  Forward/Sparse  01:43:37/Never
    vlan1001  Forward/Sparse  01:39:18/00:03:08  
    vlan1251  Forward/Sparse  01:25:23/00:03:06  
    
  
(192.168.1.201, 225.1.0.0), uptime 01:25:24, expires 00:02:42, flags: CT
  Incoming interface: vlan1001, RPF neighbor 10.1.2.2
  Outgoing interface list:
    vlan100  Forward/Sparse  01:25:24/Never
   
 
(192.168.1.202, 225.1.0.0), uptime 01:25:24, expires 00:02:56, flags: CT
  Incoming interface: vlan1001, RPF neighbor 10.1.2.2
  Outgoing interface list:
    vlan100  Forward/Sparse  01:25:24/Never
   
 
(172.16.1.201, 225.1.0.0), uptime 01:25:24, expires 00:02:57, flags: CFT
  Incoming interface: vlan100, RPF neighbor 0.0.0.0
  Outgoing interface list:
    vlan1001  Forward/Sparse  01:25:24/00:03:13  
    vlan1251  Forward/Sparse  01:25:23/00:03:06

The show ip pim mcache command displays the multicast route entries.

CR2# show ip pim mcache
PIM Multicast Routing Cache Table
 
(192.168.1.201, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan1
     
(192.168.1.202, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan1
     
(172.16.1.201, 225.1.0.0)
  Incoming interface : vlan1
  Outgoing interface list :
   vlan1001
   vlan1251

The show ip pim mcache vlt command displays the multicast route entries synchronized between the VLT peers.

CR2# show ip pim mcache vlt
PIM Multicast Routing Cache Table
Flags: S - Synced
 
(192.168.1.201, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan1
     
(192.168.1.202, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan1
     
(172.16.1.201, 225.1.0.0)
  Incoming interface : vlan1
  Outgoing interface list :
   vlan1001

The show ip pim bsr-router command displays information about the BSR.

CR2# show ip pim bsr-router 
  
 PIMv2 Bootstrap information 
    BSR address: 10.1.100.5
    BSR Priority: 199, Hash mask length: 31
    Expires: 00:00:17
    This system is a candidate BSR
    Candidate BSR address: 10.1.100.6, priority: 99, hash mask length: 31
    Next Cand_RP_advertisement in 00:00:24
    RP: 10.1.100.6(loopback1)

The show ip pim rp mapping command displays information about all multicast group-to-RP mappings.

CR2# show ip pim rp 
Group           RP
---------------------------------
225.1.0.0       10.1.100.6
CR2# show ip pim rp mapping
Group(s) : 225.0.0.0/8
RP : 10.1.100.5, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:00:58 
Group(s) : 225.0.0.0/8
RP : 10.1.100.6, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:00:39

The show ip igmp snooping groups command displays the IGMP database.

CR2# show ip igmp snooping groups
Total Number of Groups: 320
CR2# show ip igmp snooping groups vlan 1 225.1.0.0 detail 
Interface      vlan1
Group          225.1.0.0
Source List
 --                  
   Member Port         Mode                Uptime              Expires                       
   port-channel1000    IGMPv2-Compat       01:57:20            00:01:39                      
   ethernet1/1/28:4    IGMPv2-Compat       01:57:31            00:01:39

AG1

The show ip pim interface command displays the PIM-enabled interfaces on the node.

AG1# show ip pim interface 
Address    Interface  Ver/Mode Nbr Count Query Intvl DR Prio      DR
-----------------------------------------------------------------------------
10.1.2.1    vlan1001   v2/S     3          30         1           10.1.2.6           
10.112.1.1  vlan1301   v2/S     3          30         1           10.112.1.4           
192.168.1.4 vlan2001   v2/S     3          30         4294967295  192.168.1.4

The show ip pim neighbor command displays the PIM neighbor of the node and the interface to reach the neighbor.

AG1# show ip pim neighbor
Neighbor Address  Interface   Uptime/Expires      Ver  DR Priority / Mode
------------------------------------------------------------------------------
10.1.2.2          vlan1001    00:19:45/00:01:29   v2    1          / S           
10.1.2.5          vlan1001    00:24:18/00:01:32   v2    1          / S           
10.1.2.6          vlan1001    00:24:19/00:01:29   v2    1          / DR S        
10.112.1.2        vlan1301    00:19:52/00:01:22   v2    1          / S           
10.112.1.3        vlan1301    00:22:14/00:01:24   v2    1          / S           
10.112.1.4        vlan1301    00:20:38/00:01:22   v2    1          / DR S        
192.168.1.3       vlan2001    00:19:51/00:01:23   v2    4294967290 / S           
192.168.1.2       vlan2001    00:22:11/00:01:23   v2    100000     / S           
192.168.1.1       vlan2001    00:20:36/00:01:25   v2    1          / S

The show ip pim summary command displays the PIM summary.

AG1# show ip pim summary 
  
Entries in PIM-TIB/MFC: 140/80  
  
Active Modes:
    PIM-SM  
  
Interface summary:
    7 active PIM interfaces
    0 passive PIM interfaces
    21 active PIM neighbor
  
TIB Summary:
    20/20 (*,G) entries in PIM-TIB/MFC
    60/60 (S,G) entries in PIM-TIB/MFC
    60/0 (S,G,Rpt) entries in PIM-TIB/MFC
  
    2 RP
    3 sources
    40 Register states
  
Message Summary:
    418/386 Joins/Prunes sent/received
    0/0 Candidate-RP advertisements sent/received
    597/1827 BSR messages sent/received
  
    0 Null Register messages received
    0/459 Register-stop messages sent/received
  
Data path event summary:
    20 last-hop switchover messages received
    23/159 pim-assert messages sent/received
    499/0 register messages sent/received
  
VLT Multicast summary:
    0(*,G) synced entries in MFC
    0(S,G) synced entries in MFC
    0(S,G,Rpt) synced entries in MFC

The show ip pim tib command displays the PIM tree information base (TIB).

AG1# show ip pim tib 
  
PIM Multicast Routing Table
Flags: S - Sparse, C - Connected, L - Local, P - Pruned,
       R - RP-bit set, F - Register Flag, T - SPT-bit set, J - Join SPT,
       K - Ack-Pending state
Timers: Uptime/Expires
Interface state: Interface, next-Hop, State/Mode
 
(*, 225.1.0.0), uptime 01:39:47, expires 00:00:09, RP 10.1.100.6, flags: SCJ
  Incoming interface: vlan1001, RPF neighbor 10.1.2.6
  Outgoing interface list:
    vlan2001  Forward/Sparse  01:39:47/Never
    vlan2002  Forward/Sparse  01:39:41/Never
    vlan2003  Forward/Sparse  01:39:44/Never
    vlan2004  Forward/Sparse  01:39:44/Never
    vlan2005  Forward/Sparse  01:39:43/Never
    
  
(192.168.1.201, 225.1.0.0), uptime 01:25:53, expires 00:01:14, flags: CFT
  Incoming interface: vlan2001, RPF neighbor 0.0.0.0
  Outgoing interface list:
    vlan2002  Forward/Sparse  01:25:53/Never
    vlan2003  Forward/Sparse  01:25:53/Never
    vlan2004  Forward/Sparse  01:25:53/Never
    vlan2005  Forward/Sparse  01:25:53/Never
   
 
(192.168.1.202, 225.1.0.0), uptime 01:25:53, expires 00:01:14, flags: CFT
  Incoming interface: vlan2001, RPF neighbor 0.0.0.0
  Outgoing interface list:
    vlan2002  Forward/Sparse  01:25:53/Never
    vlan2003  Forward/Sparse  01:25:53/Never
    vlan2004  Forward/Sparse  01:25:53/Never
    vlan2005  Forward/Sparse  01:25:53/Never
   
 
(172.16.1.201, 225.1.0.0), uptime 01:22:46, expires 00:01:15, flags: CT
  Incoming interface: vlan1001, RPF neighbor 10.1.2.6
  Outgoing interface list:
    vlan2002  Forward/Sparse  01:22:46/Never
    vlan2003  Forward/Sparse  01:22:46/Never
    vlan2004  Forward/Sparse  01:22:46/Never
    vlan2005  Forward/Sparse  01:22:46/Never

The show ip pim mcache command displays the multicast route entries.

AG1# show ip pim mcache
PIM Multicast Routing Cache Table
 
(*, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan2002
   vlan2003
   vlan2004
   vlan2005
     
(192.168.1.201, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
   vlan1001
   vlan2002
   vlan2003
   vlan2004
   vlan2005
     
(192.168.1.202, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
   vlan1001
   vlan2002
   vlan2003
   vlan2004
   vlan2005
     
(172.16.1.201, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan2002
   vlan2003
   vlan2004
   vlan2005

The show ip pim mcache vlt command displays the multicast route entries synchronized between the VLT peers.

AG1# show ip pim mcache vlt  | no-more
PIM Multicast Routing Cache Table
Flags: S - Synced
 
(*, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan2002
   vlan2003
   vlan2004
   vlan2005
     
(192.168.1.201, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
   vlan1001 (S)
   vlan2002
   vlan2003
   vlan2004
   vlan2005
     
(192.168.1.202, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
   vlan1001 (S)
   vlan2002
   vlan2003
   vlan2004
   vlan2005
     
(172.16.1.201, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan2002
   vlan2003
   vlan2004
   vlan2005

The show ip pim bsr-router command displays information about the BSR.

AG1# show ip pim bsr-router
  
 PIMv2 Bootstrap information 
    BSR address: 10.1.100.5
    BSR Priority: 199, Hash mask length: 31
    Expires: 00:00:23

The show ip pim rp mapping command displays information about all multicast group-to-RP mappings.

AG1# show ip pim rp 
Group           RP
---------------------------------
225.1.0.0       10.1.100.6
AG1# show ip pim rp mapping 
Group(s) : 225.0.0.0/8
RP : 10.1.100.5, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:00:45 
Group(s) : 225.0.0.0/8
RP : 10.1.100.6, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:00:56 

The show ip igmp snooping groups command displays the IGMP database.

AG1# show ip igmp snooping groups
Total Number of Groups: 1600
AG1# show ip igmp snooping groups vlan 2001 225.1.0.0 detail
Interface      vlan2001
Group          225.1.0.0
Source List
 --                  
   Member Port         Mode                Uptime              Expires                       
   port-channel1       Exclude             01:53:40            00:01:35                      
   port-channel1000    IGMPv2-Compat       01:53:16            00:01:41                      
   port-channel41      Exclude             01:53:37            00:01:37                      
   ethernet1/1/6:2     IGMPv2-Compat       01:53:34            00:01:41

AG2

The show ip pim interface command displays the PIM-enabled interfaces on the node.

AG2# show ip pim interface
Address    Interface  Ver/Mode Nbr Count Query Intvl DR Prio      DR
-----------------------------------------------------------------------------
192.168.1.3 vlan2001    v2/S     3         30         4294967290  192.168.1.4           
10.112.1.2  vlan1301    v2/S     3         30         1           10.112.1.4           
10.1.2.2    vlan1001    v2/S     3         30         1           10.1.2.6    

The show ip pim neighbor command displays the PIM neighbor of the node and the interface to reach the neighbor.

AG2# show ip pim neighbor
Neighbor Address  Interface   Uptime/Expires     Ver  DR Priority / Mode
------------------------------------------------------------------------
192.168.1.4        vlan2001   00:21:42/00:01:38  v2   4294967295 / DR S        
192.168.1.2        vlan2001   00:21:50/00:01:38  v2   100000     / S           
192.168.1.1        vlan2001   00:20:39/00:01:39  v2   1          / S           
10.112.1.1         vlan1301   00:22:29/00:01:40  v2   1          / S           
10.112.1.3         vlan1301   00:22:29/00:01:38  v2   1          / S           
10.112.1.4         vlan1301   00:20:39/00:01:36  v2   1          / DR S        
10.1.2.1           vlan1001   00:22:44/00:01:44  v2   1          / S           
10.1.2.5           vlan1001   00:22:33/00:01:17  v2   1          / S           
10.1.2.6           vlan1001   00:22:34/00:01:44  v2   1          / DR S  

The show ip pim summary command displays the PIM summary.

AG2# show ip pim summary
   
Entries in PIM-TIB/MFC: 60/40  
  
Active Modes:
    PIM-SM  
  
Interface summary:
    7 active PIM interfaces
    0 passive PIM interfaces
    21 active PIM neighbor
  
TIB Summary:
    20/0 (*,G) entries in PIM-TIB/MFC
    40/40 (S,G) entries in PIM-TIB/MFC
    0/0 (S,G,Rpt) entries in PIM-TIB/MFC
  
    2 RP
    2 sources
    0 Register states
  
Message Summary:
    63/775 Joins/Prunes sent/received
    0/0 Candidate-RP advertisements sent/received
    587/1895 BSR messages sent/received
  
    0 Null Register messages received
    0/0 Register-stop messages sent/received
  
Data path event summary:
    0 last-hop switchover messages received
    22/162 pim-assert messages sent/received
    0/0 register messages sent/received
  
VLT Multicast summary:
    20(*,G) synced entries in MFC
    20(S,G) synced entries in MFC
    0(S,G,Rpt) synced entries in MFC

The show ip pim tib command displays the PIM tree information base (TIB).

AG2# show ip pim tib
  
PIM Multicast Routing Table
Flags: S - Sparse, C - Connected, L - Local, P - Pruned,
       R - RP-bit set, F - Register Flag, T - SPT-bit set, J - Join SPT,
       K - Ack-Pending state
Timers: Uptime/Expires
Interface state: Interface, next-Hop, State/Mode
 
(*, 225.1.0.0), uptime 01:40:01, expires 00:00:00, RP 10.1.100.6, flags: SC
  Incoming interface: vlan1001, RPF neighbor 10.1.2.6
  Outgoing interface list:
    vlan2001  Forward/Sparse  01:39:57/Never
    vlan2002  Forward/Sparse  01:40:01/Never
    vlan2003  Forward/Sparse  01:39:55/Never
    vlan2004  Forward/Sparse  01:39:51/Never
    vlan2005  Forward/Sparse  01:39:52/Never
    
  
(192.168.1.201, 225.1.0.0), uptime 01:26:21, expires 00:01:10, flags: CT
  Incoming interface: vlan2001, RPF neighbor 0.0.0.0
  Outgoing interface list:
    vlan1001  Forward/Sparse  01:26:21/00:03:09  
   
 
(192.168.1.202, 225.1.0.0), uptime 01:26:21, expires 00:01:10, flags: CT
  Incoming interface: vlan2001, RPF neighbor 0.0.0.0
  Outgoing interface list:
    vlan1001  Forward/Sparse  01:26:21/00:03:09

The show ip pim mcache command displays the multicast route entries.

AG2# show ip pim mcache
PIM Multicast Routing Cache Table
 
(*, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan2002
   vlan2003
   vlan2004
   vlan2005
     
(192.168.1.201, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
   vlan1001
   vlan2002
   vlan2003
   vlan2004
   vlan2005
     
(192.168.1.202, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
   vlan1001
   vlan2002
   vlan2003
   vlan2004
   vlan2005
     
(172.16.1.201, 225.1.0.0)
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan2002
   vlan2003
   vlan2004
   vlan2005

The show ip pim mcache vlt command displays the multicast route entries synchronized between the VLT peers.

AG2# show ip pim mcache vlt  | no-more
PIM Multicast Routing Cache Table
Flags: S - Synced
 
(*, 225.1.0.0),flags: S
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan2002 (S)
   vlan2003 (S)
   vlan2004 (S)
   vlan2005 (S)
     
(192.168.1.201, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
   vlan1001
   vlan2002 (S)
   vlan2003 (S)
   vlan2004 (S)
   vlan2005 (S)
     
(192.168.1.202, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
   vlan1001
   vlan2002 (S)
   vlan2003 (S)
   vlan2004 (S)
   vlan2005 (S)
     
(172.16.1.201, 225.1.0.0),flags: S
  Incoming interface : vlan1001
  Outgoing interface list :
   vlan2002 (S)
   vlan2003 (S)
   vlan2004 (S)
   vlan2005 (S)

The show ip pim bsr-router command displays information about the BSR.

AG2# show ip pim bsr-router
  
 PIMv2 Bootstrap information 
    BSR address: 10.1.100.5
    BSR Priority: 199, Hash mask length: 31
    Expires: 00:00:26

The show ip pim rp mapping command displays information about all multicast group-to-RP mappings.

AG2# show ip pim rp 
Group           RP
---------------------------------
225.1.0.0       10.1.100.6
AG2# show ip pim rp mapping
Group(s) : 225.0.0.0/8
RP : 10.1.100.5, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:01:03 
Group(s) : 225.0.0.0/8
RP : 10.1.100.6, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:00:44

The show ip igmp snooping groups command displays the IGMP database.

AG2# show ip igmp snooping groups
Total Number of Groups: 1600
AG2# show ip igmp snooping groups vlan 2001 225.1.0.0 detail
Interface      vlan2001
Group          225.1.0.0
Source List
 --                  
   Member Port         Mode                Uptime              Expires                       
   port-channel1       Exclude             01:51:31            00:01:30                      
   port-channel1000    IGMPv2-Compat       01:53:27            00:01:36                      
   port-channel41      Exclude             01:50:30            00:01:32                      
   ethernet1/1/6:2     IGMPv2-Compat       01:51:28            00:01:30

AG3

The show ip pim interface command displays the PIM-enabled interfaces on the node.

AG3# show ip pim interface
Address    Interface  Ver/Mode  Nbr Count  Query Intvl  DR Prio   DR
-----------------------------------------------------------------------------
10.112.1.3  vlan1301   v2/S       3         30            1       10.112.1.4           
192.168.1.2 vlan2001   v2/S       3         30            100000  192.168.1.4           
10.110.1.3  vlan1151   v2/S       1         30            1       10.110.1.5           
10.1.3.3    vlan1101   v2/S       1         30            1       10.1.3.5

The show ip pim neighbor command displays the PIM neighbor of the node and the interface to reach the neighbor.

AG3# show ip pim neighbor
Neighbor Address  Interface  Uptime/Expires     Ver  DR Priority / Mode
------------------------------------------------------------------------
10.112.1.1        vlan1301   00:22:45/00:01:24  v2   1          / S           
10.112.1.2        vlan1301   00:20:24/00:01:20  v2   1          / S           
10.112.1.4        vlan1301   00:21:09/00:01:20  v2   1          / DR S        
192.168.1.4       vlan2001   00:22:47/00:01:22  v2   4294967295 / DR S        
192.168.1.3       vlan2001   00:20:22/00:01:22  v2   4294967290 / S           
192.168.1.1       vlan2001   00:21:07/00:01:23  v2   1          / S           
10.110.1.5        vlan1151   00:22:58/00:01:16  v2   1          / DR S        
10.1.3.5          vlan1101   00:23:05/00:01:38  v2   1          / DR S

The show ip pim summary command displays the PIM summary.

AG3# show ip pim summary
   
Entries in PIM-TIB/MFC: 60/40  
  
Active Modes:
    PIM-SM  
  
Interface summary:
    8 active PIM interfaces
    0 passive PIM interfaces
    20 active PIM neighbor
  
TIB Summary:
    20/0 (*,G) entries in PIM-TIB/MFC
    40/40 (S,G) entries in PIM-TIB/MFC
    0/0 (S,G,Rpt) entries in PIM-TIB/MFC
  
    2 RP
    2 sources
    0 Register states
  
Message Summary:
    40/20 Joins/Prunes sent/received
    0/0 Candidate-RP advertisements sent/received
    680/1899 BSR messages sent/received
  
    0 Null Register messages received
    0/0 Register-stop messages sent/received
  
Data path event summary:
    0 last-hop switchover messages received
    22/164 pim-assert messages sent/received
    0/0 register messages sent/received
  
VLT Multicast summary:
    0(*,G) synced entries in MFC
    0(S,G) synced entries in MFC
    0(S,G,Rpt) synced entries in MFC

The show ip pim tib command displays the PIM tree information base (TIB).

AG3# show ip pim tib 
  
PIM Multicast Routing Table
Flags: S - Sparse, C - Connected, L - Local, P - Pruned,
       R - RP-bit set, F - Register Flag, T - SPT-bit set, J - Join SPT,
       K - Ack-Pending state
Timers: Uptime/Expires
Interface state: Interface, next-Hop, State/Mode
 
(*, 225.1.0.0), uptime 01:39:57, expires 00:00:00, RP 10.1.100.6, flags: SC
  Incoming interface: vlan1151, RPF neighbor 10.110.1.5
  Outgoing interface list:
    vlan2001  Forward/Sparse  01:39:57/Never
    vlan2002  Forward/Sparse  01:39:57/Never
    vlan2003  Forward/Sparse  01:39:57/Never
    vlan2004  Forward/Sparse  01:39:57/Never
    vlan2005  Forward/Sparse  01:39:57/Never
    
  
(192.168.1.201, 225.1.0.0), uptime 01:26:40, expires 00:00:52, flags: CTP
  Incoming interface: vlan2001, RPF neighbor 0.0.0.0
  Outgoing interface list:
   
 
(192.168.1.202, 225.1.0.0), uptime 01:26:40, expires 00:00:52, flags: CTP
  Incoming interface: vlan2001, RPF neighbor 0.0.0.0
  Outgoing interface list:

The show ip pim mcache command displays the multicast route entries.

AG3# show ip pim mcache
PIM Multicast Routing Cache Table
 
(192.168.1.201, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
     
(192.168.1.202, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :

The show ip pim bsr-router command displays information about the BSR.

AG3# show ip pim bsr-router
  
 PIMv2 Bootstrap information 
    BSR address: 10.1.100.5
    BSR Priority: 199, Hash mask length: 31
    Expires: 00:00:30

The show ip pim rp mapping command displays information about all multicast group-to-RP mappings.

AG3# show ip pim rp 
Group           RP
--------------------------------
225.1.0.0       10.1.100.6
AG3# show ip pim rp mapping
Group(s) : 225.0.0.0/8
RP : 10.1.100.5, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:00:43 
Group(s) : 225.0.0.0/8
RP : 10.1.100.6, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:00:54

The show ip igmp snooping groups command displays the IGMP database.

AG3# show ip igmp snooping groups
Total Number of Groups: 1600
AG3# show ip igmp snooping groups vlan 2001 225.1.0.0 detail
Interface      vlan2001
Group          225.1.0.0
Source List
 --                  
   Member Port         Mode                Uptime              Expires                       
   port-channel1       Exclude             01:53:46            00:01:28                      
   port-channel1000    IGMPv2-Compat       01:54:04            00:01:29                      
   port-channel51      Exclude             01:54:40            00:01:23                      
   ethernet1/1/32:2    IGMPv2-Compat       01:54:04            00:01:28

AG4

The show ip pim interface command displays the PIM-enabled interfaces on the node.

AG4# show ip pim interface 
Address     Interface  Ver/Mode  Nbr Count  Query Intvl  DR Prio  DR
------------------------------------------------------------------------------
10.1.4.4     vlan1201   v2/S      1           30           1      10.1.4.5           
10.112.1.4   vlan1301   v2/S      3           30           1      10.112.1.4           
192.168.1.1  vlan2001   v2/S      3           30           1      192.168.1.4           
10.192.168.4 vlan1251   v2/S      1           30           1      10.192.168.5

The show ip pim neighbor command displays the PIM neighbor of the node and the interface to reach the neighbor.

AG4# show ip pim neighbor
Neighbor Address  Interface  Uptime/Expires     Ver  DR Priority / Mode
-----------------------------------------------------------------------
10.1.4.5          vlan1201   00:22:44/00:01:35  v2   1          / DR S        
10.112.1.1        vlan1301   00:22:52/00:01:43  v2   1          / S           
10.112.1.2        vlan1301   00:20:35/00:01:40  v2   1          / S           
10.112.1.3        vlan1301   00:23:26/00:01:42  v2   1          / S           
192.168.1.4       vlan2001   00:22:52/00:01:41  v2   4294967295 / DR S        
192.168.1.3       vlan2001   00:20:33/00:01:41  v2   4294967290 / S           
192.168.1.2       vlan2001   00:23:50/00:01:41  v2   100000     / S           
10.192.168.5      vlan1251   00:22:37/00:01:39  v2   1          / DR S

The show ip pim summary command displays the PIM summary.

AG4# show ip pim summary
    
Entries in PIM-TIB/MFC: 140/80  
  
Active Modes:
    PIM-SM  
  
Interface summary:
    8 active PIM interfaces
    0 passive PIM interfaces
    20 active PIM neighbor
  
TIB Summary:
    20/20 (*,G) entries in PIM-TIB/MFC
    60/60 (S,G) entries in PIM-TIB/MFC
    60/0 (S,G,Rpt) entries in PIM-TIB/MFC
  
    2 RP
    3 sources
    0 Register states
  
Message Summary:
    389/0 Joins/Prunes sent/received
    0/0 Candidate-RP advertisements sent/received
    687/1944 BSR messages sent/received
  
    0 Null Register messages received
    0/0 Register-stop messages sent/received
  
Data path event summary:
    22 last-hop switchover messages received
    120/67 pim-assert messages sent/received
    0/0 register messages sent/received
  
VLT Multicast summary:
    0(*,G) synced entries in MFC
    0(S,G) synced entries in MFC
    0(S,G,Rpt) synced entries in MFC

The show ip pim tib command displays the PIM tree information base (TIB).

AG4# show ip pim tib
  
PIM Multicast Routing Table
Flags: S - Sparse, C - Connected, L - Local, P - Pruned,
       R - RP-bit set, F - Register Flag, T - SPT-bit set, J - Join SPT,
       K - Ack-Pending state
Timers: Uptime/Expires
Interface state: Interface, next-Hop, State/Mode
 
(*, 225.1.0.0), uptime 01:40:17, expires 00:00:58, RP 10.1.100.6, flags: SCJ
  Incoming interface: vlan1251, RPF neighbor 10.192.168.5
  Outgoing interface list:
    vlan2001  Forward/Sparse  01:40:17/Never
    vlan2002  Forward/Sparse  01:40:09/Never
    vlan2003  Forward/Sparse  01:40:04/Never
    vlan2004  Forward/Sparse  01:40:04/Never
    vlan2005  Forward/Sparse  01:40:04/Never
    
  
(192.168.1.201, 225.1.0.0), uptime 01:27:01, expires 00:00:30, flags: CTP
  Incoming interface: vlan2001, RPF neighbor 0.0.0.0
  Outgoing interface list:
   
 
(192.168.1.202, 225.1.0.0), uptime 01:27:01, expires 00:00:30, flags: CTP
  Incoming interface: vlan2001, RPF neighbor 0.0.0.0
  Outgoing interface list:
   
 
(172.16.1.201, 225.1.0.0), uptime 01:27:01, expires 00:00:31, flags: CT
  Incoming interface: vlan1251, RPF neighbor 10.192.168.5
  Outgoing interface list:
    vlan2001  Forward/Sparse  01:27:01/Never

The show ip pim mcache command displays the multicast route entries.

AG4# show ip pim mcache
PIM Multicast Routing Cache Table
 
(*, 225.1.0.0)
  Incoming interface : vlan1251
  Outgoing interface list :
   vlan2001
     
(192.168.1.201, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
     
(192.168.1.202, 225.1.0.0)
  Incoming interface : vlan2001
  Outgoing interface list :
     
(172.16.1.201, 225.1.0.0)
  Incoming interface : vlan1251
  Outgoing interface list :
   vlan2001

The show ip pim bsr-router command displays information about the BSR.

AG4# show ip pim bsr-router
  
 PIMv2 Bootstrap information 
    BSR address: 10.1.100.5
    BSR Priority: 199, Hash mask length: 31
    Expires: 00:00:20

The show ip pim rp mapping command displays information about all multicast group-to-RP mappings.

AG4# show ip pim rp 
Group           RP
---------------------------------
225.1.0.0       10.1.100.6
AG4# show ip pim rp mapping
Group(s) : 225.0.0.0/8
RP : 10.1.100.5, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:01:02 
Group(s) : 225.0.0.0/8
RP : 10.1.100.6, v2
  Info source: 10.1.100.5, via bootstrap, priority 100
     expires: 00:00:43 

The show ip igmp snooping groups command displays the IGMP database.

AG4# show ip igmp snooping groups 
Total Number of Groups: 1600
AG4# show ip igmp snooping groups vlan 2001 225.1.0.0 detail
Interface      vlan2001
Group          225.1.0.0
Source List
 --                  
   Member Port         Mode                Uptime              Expires                       
   port-channel1       Exclude             01:52:34            00:01:26                      
   port-channel1000    IGMPv2-Compat       01:54:04            00:01:27                      
   port-channel51      Exclude             01:52:49            00:01:21                      
   ethernet1/1/32:2    IGMPv2-Compat       01:53:42            00:01:27

TR1

The show ip igmp snooping groups command displays the IGMP database.

TR1# show ip igmp snooping groups
Total Number of Groups: 1600
TR1# show ip igmp snooping groups vlan 2001 225.1.0.0 detail
Interface      vlan2001
Group          225.1.0.0
Source List
 --                  
   Member Port         Mode                Uptime              Expires                       
   ethernet1/1/31      IGMPv2-Compat       01:56:02            00:01:17                      
   ethernet1/1/32      IGMPv2-Compat       01:56:02            00:01:21  

TR2

The show ip igmp snooping groups command displays the IGMP database.

TR2# show ip igmp snooping groups
Total Number of Groups: 1600
TR2# show ip igmp snooping groups vlan 2001
Total Number of Groups: 20
IGMP Connected Group Membership
Group Address                 Interface           Mode                Expires             
225.1.0.0                     vlan2001            IGMPv2-Compat       00:01:36            
  Member-ports :ethernet1/1/21,ethernet1/1/22
225.1.0.1                     vlan2001            IGMPv2-Compat       00:01:36            
  Member-ports :ethernet1/1/21,ethernet1/1/22
225.1.0.2                     vlan2001            IGMPv2-Compat       00:01:36            
  Member-ports :ethernet1/1/21,ethernet1/1/22

<<Output_truncated>>

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\